えもふりロゴ

・モーション作成の手順・

.ver 20170209

有限会社M2

はじめに

本マニュアルでは、「キャラクター原画作成の手順」で作成したPSDキャラクターを、E-mote3.8エディタに導入、細部の細部の調整、具体的なモーションの作成手順を説明します。E-moteのバージョンアップにより、仕様や内容の一部が変更される可能性がありますが、その際はツールよりアクセス可能なオフィシャルオンラインマニュアルをご参照下さい。

※ 今回更新のE-mote3.8以降新機能に関しましては、えもふりver3.5ではご利用できません。ご注意ください。

index

キャラクター原画作成の手順


1.基本説明・設定調整

1-1.エディタの基本説明

E-moteエディタでは、.psd形式、または.png形式で作成したキャラクターを登録し、キャラクターパラメータを操作しながら様々な表情やポーズを滑らかな動きで切り替え、表現・保存・出力する事がでるツールです。エディタ左の「編集モードツリー」から調整したい項目ごとに編集モードを切り替え、「基本編集画面」で編集を行います。

※ png形式を使用する場合は、ver2.0形式の作成手順が必要となりますので、ver2.0オンラインマニュアルをご参照下さい。

1-1.エディタの基本説明

1-2.エディタの基本機能・基本設定

エディタ右上の項目から、様々な機能を選択する事が出来ます。

ここでは、大まかな説明のみ行います。細かな用途などは各章内を参照して下さい。


【ファイル】

各種ファイルのインポート・エクスポートを行います。

PSDで作成したキャラクター画像のインポート、E-moteキャラクターデータ(.mmo)の読み込み・保存、ソフトウェア用キャラクターデータ(.psb)のエクスポートなども、ここで行います。

ファイル


【編集】

作業状態の編集、キーボードショートカットの設定、E-moteキャラクターの左右反転(ミラー化)が行えます。 ※ 本マニュアル内では、キーボードショートカットはすべて初期設定のままとして説明しています。

【編集】


【表示】

画面の拡縮、背景画像の変更が出来ます。

これらの操作はキーボードショートカットでも可能です。


【ヘルプ】

この項目から直接、オンラインマニュアルの参照、テンプレートフォルダやSDKフォルダ、問い合わせフォームへのアクセスが出来ます。オンラインマニュアルは、エディタの更新がある度に随時更新してゆきます。

【編集】


2.テンプレートファイルの準備・キャラクターのインポート

ここでは、E-moteエディタにテンプレートファイルとPSDデータを読み込み、 キャラクター編集前の基本的な手順を説明します。

E-moteキャラクターを作成する際には、[E-moteエディタ][テンプレートファイル(.mmo)][PSDデータ(.psd)]の3つが必要となります。本マニュアルでは、基本セットに同梱されているサンプルデータを元に説明を進めてゆきます。

※ ご注意!
E-mote3.8テンプレートは、高機能である為ノーマル版のE-moteエディタでは正常にインポートできません。
E-mote3.8テンプレートを使用する際は、後述のE-moteエディタZバイナリ版(64bitOS環境下)をご使用ください。

テンプレートファイルの準備・キャラクターのインポート

最新版テンプレート・及びサンプルファイルについては、
ヘルプメニューの[サンプルキャラクターファイル]からダウンロードできます。
斜め向きテンプレートや作例・性格ごとのタイムラインなど多数保存されていますので、ご活用下さい。

テンプレートファイルの準備・キャラクターのインポート

2-1.テンプレートファイルの読み込み

E-moteエディタを起動。[ファイル]-[プロジェクトを開く]から テンプレートファイルを読み込み、テンプレートキャラクターを表示します。

2-2.PSDファイルの読み込み

次に、[ファイル]-[PSDをインポートする]から、作成しておいたPSDファイルを読み込みます。

読み込みが完了すると、「PSDインポート画面」が起動します。

※ 「PSDを2つまとめてインポートする」に関しては、後述の「4-13 特殊な機能」をご参照下さい。

PSDファイルの読み込み

2-3.物理挙動スケールの設定

[取り込みパーツ一覧]から、[物理挙動スケール調整]を選択します。

物理挙動スケール調整

プレビュー画面に表示されるPSD画像と比べながら[スケール]のスクロールバーを調整して、表示されているキャラクターの体格が大よそ同じ程度になるように調整します。

スケールを揃える事により、髪などを揺らす際の物理挙動(揺れ幅や動きの限界値)が正しく動作するようになります

スケール
スケール

2-4.パーツとレイヤー名の確認

次に、それぞれの[取り込みパーツ]が正しく取り込まれているか、レイヤー名との関連付けが正しいかを確認し、必要であればパーツとレイヤー名の組み合わせを変更します

尚、取り込みパーツの状態は、パーツ一覧の文字色で判断できます。


[黒字表示]

パーツに符合するレイヤー名が見つかり、正常に取り込まれています。


[灰色表示]

レイヤー名が未選択になっています。

PSD側のレイヤー名が間違っているか、存在ていない(省略された)状態です。

このままインポートした場合は、自動的にパーツが無効化されます。(2-5で説明しているようにPSD側で設定して、再度インポートすると復活します)


[赤色表示]

「枠」「中心」系統のレイヤーが見つかっていません。

「目枠」や「クチ枠」の場合は、インポート後に枠の中身ごと無効化されます

必要なかったり、あえて省略したパーツの場合は、このまま無視してしまっても問題ありませんが、「原点」「首中心」「腰中心」「頭部全体枠」「胴体全体枠」「輪郭」「胴体」については必須項目です。

設定されていない場合はインポート後に正しく動作しなくなる可能性があります。


[青色表示]

PSDインポートで新たに追加された追加パーツです。

「追加_●●●」「追加パーツ_xxx」といったレイヤー名の場合は、インポート時に自動的に一覧に追加されます


[緑色表示]

パーツ属性が編集された追加パーツです。

基本的に、全て青字→緑字となるようにしてからインポート完了とします。追加パーツは、次回再度PSDインポートした際には黒字表示されます

パーツとレイヤー名の確認

2-5.基本パーツとレイヤーの設定変更

「取り込みパーツ一覧」の各パーツを選択すると、設定項目とパーツ切り出し枠が表示されます。

必要な場合は、これらの設定を変更することができます。これら変更した項目は、mmoファイル内に保存され、PSDの再インポート時にはそのまま適用されます。


[ブレンドモード自動設定]

PSDレイヤの属性を読み取ってインポート時に反映します。適用できる属性は通常・乗算・スクリーン・焼き込み(リニア)・覆い焼き(リニア)の5種類のみです。


[パーツ削除]

パーツをE-mote上で表示しないよう、削除します。削除されたパーツはpsbエクスポート時にテクスチャ・メッシュ情報が含まれなくなり、その分ファイルサイズや処理が軽減します。


[レイヤマスク適用]

PSDレイヤのレイヤマスクの適用・不適用を選択できます。


[PSDレイヤ・枠PSDレイヤ・アイコンPSDレイヤ]

ボタンをクリックするとPSDレイヤ名の一覧が表示され、選択パーツとレイヤ名の関連付けを変更する事ができます。

[<フォルダ名>フォルダ合成]を選択する事で、レイヤフォルダごと合成した画像を1つのパーツとして扱うこともできます。

基本パーツとレイヤーの設定変更

2-6.パーツの取り込み枠調整

輪郭や胴体などのパーツは、PSDレイヤーの透明部分を認識して自動的に取り込み枠(青色破線)を設定しています。この枠を直接ドラッグしたり、枠内で右クリックする事で枠のサイズを調整、変更する事ができます(自動で設定された取り込み枠は、不透明部分の境目から上下左右5%のマージンを持つように設定されています。

パーツの取り込み枠調整

[取り込み枠をリセット]

取り込み枠の変更をリセットし、初期取り込みの枠サイズに戻します。


[取り込み枠を他のパーツに合わせる]

他パーツの枠サイズ・位置をそのままコピーします。


[取り込み枠をPSDレイヤに合わせる]

PSDレイヤの透明部分から矩形を作成し、取り込み枠とします。PSDフォルダを枠とする事も可能です。

2-7.取り込み設定

取り込み設定の項目からは、インポート時の一括設定や登録情報のリセット、手動での追加パーツ登録、削除ができます。


[自動レイアウト調整]

チェックをオフにすると、PSDインポート時のパーツ座標の調整をしません。 PSDからパーツ画像のみを更新したい時などに使用します。

取り込み設定

[自動Z座標調整]

チェックをオフにすると、PSDインポート時のZ座標の調整をしません。

パーツの重ね順を変更されたく無い時に使用します。


[リセット]

全ての取り込み枠、パーツとレイヤ名の組み合わせなどを初期状態に戻します。

追加パーツの登録情報もリセットされますので、再インポート時には全ての追加パーツも新規に自動追加し直します。

新規psdをインポートした直後や、または[原点]レイヤーを変更したり、 画像全体のサイズを変更したpsdをインポートして、キャラクターパーツの表示がおかしくなった場合は、 一度リセットしてから再インポートして下さい。


[新規追加パーツ][追加パーツ取り消し]

新たに追加パーツを作成または削除します。

レイヤー未定義状態で作成されますので、文字色は灰色です。

2-8.追加パーツタイプの設定

パーツ一覧に追加された、それぞれの追加パーツの「パーツタイプ」を選択します。

パーツタイプは、追加パーツの動きを決める重要な選択で、エディタ上でのタイプ変更は出来ません。この項では、タイプ選択の目安を説明します(追加パーツをエディタ上で一旦削除して、psd再インポート時に作成し直す事は可能です)


追加位置とパーツタイプ

追加パーツは、「パーツを追加する場所」と、「追加するパーツのタイプ」の 大きく2つのカテゴリを組合わせて使用します。

この組合わせによって、様々な表現が可能となります

追加パーツタイプの設定

【パーツ追加位置一覧】

パーツを追加できる場所は、大まかに以下の通りです。

  • [全体]-[キャラBG]
    • 背景や足元の影など、キャラクターの動きや位置の影響を受けたくない部分に使用します。
  • [頭部]-[独立]
    • 頭と胴体の傾き影響のみを受けます。特別大きな頭飾り・帽子や、頭上の演出などに使用します。 頭向きの影響を受けない分、それぞれの向きに合わせて細かい変形設定が必要となります。
    • [頭部枠同期]

      頭部全体枠の変形影響を受け、頭部追加系では基本的にこの追加位置を使用します。 追加の髪の毛や、頭飾り、特殊な表情などに使用します。

    • [○○接着]

      ○○(頭部基本パーツ名)に直接追加します。 輪郭に付くペイントや髭、耳に付くイヤリング髪の毛のアクセサリーなどに使用します。 装着する部位より追加パーツが大きいと、異常な変形が起こりやすいので注意が必要です。

    • [頭部で切り抜き]・[輪郭で切り抜き]

      頭全体の形、または輪郭の形に追加パーツが切り抜かれます。 頭部からハミ出したくない帽子の影や前髪の影、または特殊な効果や演出表現に使用します。

  • [胴体]-[独立]
    • 胴体の傾き影響のみを受けます。背中や腰に下げている荷物、アクセサリー、翼など、胴体全体枠から大きくはみ出して配置したいパーツに使用します。
    • [胴体枠同期]

      胴体全体枠の変形影響を受けます。胴体系は基本的に、この追加位置を使用します。 首や襟の追加、胸を左右に分離したり、腰ベルトや装飾品などはほぼ表現できます。

    • [○○接着]

      頭部の「接着」同様、基本パーツに直接追加します。 基本パーツよりも追加パーツが大きくはみ出す場合は異常変形が生じますので、注意が必要です。

    • [胴体で切り抜き]

      胴体・両腕・胸・スカートと、それに付随する追加パーツのアウトラインの形にパーツが切り抜かれます。 胴体に落ちる影や、特殊な効果に使用します。

【パーツ追加位置一覧】
【パーツ追加位置一覧】

【パーツ追加位置一覧】
【パーツ追加位置一覧】

【パーツ追加位置一覧】
 
  • [腕部]-[腕○接着]

    腕の基本パーツに直接追加します。

    [腕LA][腕RA]~[腕RE][腕RE]は差分用となります。 揺れる袖や、腕のアクセサリー差分などに使用します。

  • [腕部]-[腕○接着(手持ち用)]

    この追加位置に限り、腕や胴体全体枠などの変形影響を一切受けません。 手持ちの武器や装飾など、変形させたくないパーツなどに使用します。 尚、腕の向き変形に合わせてメッシュでの位置調整は必要となります。

[腕部]-[腕○接着]
[腕部]-[腕○接着]
  • [下半身]-[独立]

    体全体の位置変更の影響のみ受けます。足元のエフェクト等に使用します。

    • [下半身同期]

      下半身パーツの変形影響から独立していますが、[下半身で切り抜き]のアウトラインに含まれます。

    • [○○接着]

      下半身パーツに直接追加する為、下半身パーツの動きに同期します。 下半身パーツから大きくはみ出す場合は、異常変形が生じます。

    • [下半身で切り抜き]

      下半身同期と足L・足R・下半身接着を含む、下半身パーツのアウトラインの形にパーツが切り抜かれます。 スカートから足に落ちる影や、特殊なエフェクトに使用します。

  • [表情] -[○○接着]

    表情用パーツに直接追加します。特殊な表情を作成したり、瞳にエフェクトを入れたり、眉間のシワや特殊な鼻を表現する際などに使用します。

  • [頭部差分] [胴体差分] [汎用差分] (ver3.8)

    分割エクスポート機能で別々のpsbとして出力し、SDK上で合成・入れ替え可能なアクセサリーパーツに細かな表現を追加する際に使用します。各パーツカテゴリ毎に選択し、他追加パーツ同様に[同期]と[接着]が選べます。親である差分パーツを無効化すると、一緒に無効化されます。


【パーツタイプ一覧】

追加できるパーツのタイプは、以下のような種類があります。

  • [揺れなし]

    追加パーツの基礎です。追加する事により、頭の上下・体の上下・頭の傾き・体の傾き・特殊な動きに合わせた変形をそれぞれ設定する事ができます。 衣装の追加やアクセサリー、硬いパーツ、ペイントなどの表現に使用します。 また、乗算やスクリーン属性にして[○○で切り抜き」と組合わせる事で、キャラクターの影や髪のハイライトにも使用できます。

  • [揺れ有り]・[揺れ(予備)]

    「揺れ無し」に揺れの機能を追加したパーツです。キャラクターが動くと、それにあわせて揺れます。 揺れ方や揺れる範囲は、それぞれ縦揺れ・横揺れ・横揺れ弛みの3つのパラメータごとに設定できます。後述の物理挙動で「揺れタイプ」を分けたい場合は、揺れ(予備)を使用します。 袖やスカートの追加、マント、腰の帯、背中の羽、振り子的なアクセサリーなど、用途は様々です。

  • [前髪揺れ] [横髪L揺れ] [横髪R揺れ] [後髪揺れ]

    基本的な構造は前述の「揺れ有り」と同じですが、それぞれの髪揺れ物理挙動に同期しています。 髪の毛の追加をしたい場合は、こちらを使用します。

  • [胸揺れ]・[胸揺れ(予備)]

    胸は特殊な揺れ構造をしている為、独立しています。 胸を左右別々に分ける際の使用だけでなく、ゴムボールのような弾み方をするパーツとしても使用できます。 また、このパーツは体の左右向きに合わせて、Z値を徐々に変化させる機能を持っています。体の左右向きに合わせて、胴体の手前から奥へ胸が回りこむ表現が可能です。

パーツタイプ
  • [揺れ&胸揺れ] [揺れ(予備)&胸揺れ(予備)] (.ver3.8追加)

    1つのパーツの中で、揺れと胸揺れが同時に使用出来ます。胸まで襟の開いた衣服や、胸と袖が繋がっているような部分に使用できます。

  • [目開閉同期] (.ver3.8機能追加)

    揺れ有りの機能に加えて、目の開閉、瞬きに同期して動く機能を持っています。
    3つめの目や、瞬きするアクセサリー、眼窩の影などの表現に使用できます。尚、揺れが必要ない場合は、PSDインポート後に揺れ情報をクリアする必要があります。
    .ver3.8テンプレートより、新たに、視線の上下左右・瞳特殊変形・マブタ特殊変形に同期する項目が追加されました。 瞳に接着して瞳孔を立体的に動かしたり、視線や感情に合わせて形状を変形させることができます。

    目開閉同期

  • [眉変形同期] (.ver3.8機能追加)

    目開閉同期の眉版です。眉の感情変化に同期する機能を持っています。揺れるほど長い眉や、眉の下の影、男性キャラクターの眉間の皺、感情に応じて変形する耳やアクセサリーなどに使用します。

    .ver3.8テンプレートより、新たに、目開閉に同期する項目が追加されました。マブタの窪みのラインなど作成し、眉の変形と干渉しないように調整することができます。

    目開閉同期

  • [口開閉同期]

    目開閉同期のクチ版です。クチの開閉に同期する機能を持っています。
    唇下の長い髭や、クチパクに同期するアクセサリーなどに使用します。

  • [fade_○揺れ] (.ver3.8追加)

    「揺れ有り」に、表示のオンオフ制御機能を追加したパーツです。
    [fade_a]~[fade_e]は、それぞれ腕差分LA RA~腕差分LE REの表示オンオフに同期しています。
    腕が差分に切り替わることで表示される影やアクセサリー、単純に腕の重ね合わせ表現などに使用します。
    .ver3.8テンプレートより、[fade_a]~[fade_e]の5つのフェードパーツは揺れと胸揺れが併用できるようになりました。これにより、腕差分に合わせた胸テクスチャ切り替えが可能となります。

    [fade_v]~[fade_z]は、完全に独立した[fade]で、腕の表示切替に関係なく表示のオンオフができます。
    特殊な表情の表現や、帽子や眼鏡などの差分制御に使用できます。
    .ver3.8テンプレートより、新たに[fade_q]~[fade_u]の5つのフェード項目が追加されました。

  • [頭部連動回り込み][胴体連動回り込み]

    頭の上下左右向き、または胴体の上下左右向きに連動して、Z値を細かに調整できるパーツです。 頭の動きに合わせて輪郭を回り込む表現や、胴体を回り込むパーツとして使用します。

[頭部連動回り込み][胴体連動回り込み]

追加パーツの組み合わせが全て完了したならば、いよいよ「インポート実行」に移ります。

2-9.インポート実行

インポート実行

最後に、[インポート]ボタンを押し、PSDインポートを実行します。

インポート実行

一度PSDインポートした後も、画像を書き換えたPSDファイルを再インポートして、設定はそのままにパーツ画像を更新する事ができます。必要に応じて、キャラクターに手を加えたり、調整を行ってください。


3.ポーズ詳細編集でテスト

PSDインポートが完了したら、一度大まかに動かしてみて不具合のある部分を確認します。

ポーズ詳細編集でテスト

E-moteは、あらかじめキャラクターに設定されている「パラメータ」の値をリアルタイムに操作、組合わせてキャラクターの表情やポーズ、仕草を表現します。

編集モードツリーの[ポーズ詳細編集]以下の4つの編集モードから、パラメータの組合わせ設定や、調整ができます。

ポーズ詳細編集でテスト

E-moteは、あらかじめキャラクターに設定されている「パラメータ」の値をリアルタイムに操作、組合わせてキャラクターの表情やポーズ、仕草を表現します。

編集モードツリーの[ポーズ詳細編集]以下の4つの編集モードから、パラメータの組合わせ設定や、調整ができます。

3-1.ポーズ詳細編集の簡易使用

まずは[パラメータ編集]または[物理挙動編集]でキャラクターの動作チェックをします。

※ 各編集モードの詳細な機能説明は、[5.モーションの編集]にて行います。


[パラメータ編集]

全てのパラメータ値を調整できます。モーションドライバに与える変数セットを作成する際は、このモードを使用します。[ctrl+マウスドラッグ]または[shift+マウスドラッグ]の操作で、頭や目の向きを簡易的に動かし、キャラクターの動作チェックができます。

ポーズ詳細編集の簡易使用
ポーズ詳細編集の簡易使用

[物理挙動編集]

物理挙動の編集と、表情遷移のパラメーターを設定できるモードです。
タイムライン(メイン)に「sample_全自動_test」を選択する事で、基本的な動作チェックができます。

[物理挙動編集]


[タイムライン編集]

フレーム(時間)とパラメーターを組み合わせて、「動きのセット」や「動きの一部」作成できるモードです。


[カタログ編集]

パラメータのセットを、「カタログ」というサムネイル画像で一覧化、編集する事ができます。

以上の動作テストによって問題の有る箇所が確認できたら、次の「4.各部パーツの編集・調整」に進みます。


4.各部パーツの編集・調整

各部パーツの編集・調整

この章では、キャラクターを実際に動かした際のおかしな部分を調整したり、新たな動きを追加する方法を説明してゆきます。 輪郭や胴体、目など全てのパーツは、大まかに「XY座標」「Z座標」「角度」「パラメータに対するメッシュ」の4つの設定から構成されています。 PSDインポート後おかしな動きをする部分は、基本的にこれらを調整する事で解消されます。

4-1.パーツ編集モードでの共通機能

パーツ編集モードでの共通機能

パーツ編集モードでは、編集画面に常時メニューが表示され、以下の機能が共通で使用できます。


[パーツ透過表示]

編集中パーツの透過オンオフを切り替えられます。
透過オン状態だと、編集中のパーツが重ね順に関係なく半透明で表示されます。

※ [END]キーでキーボードショートカットできます。


[パーツ無効化]

(E-mote3.5正式版のみ使用可能)
編集中パーツを非表示化することができます。 無効化したパーツはチェックを外すことによって元の状態に復帰します。
無効化設定されているパーツは、psbエクスポート時にはデータを無視してエクスポートされます。
※ 輪郭や胴体など、一部削除できないパーツはチェックボックスが表示されません。

パーツの無効化状態は[属性カンプパネル]で保存し、いつでも呼び出す事が出来ます。 ツリーのパーツ名に合わせて右クリックのメニューからもパーツ無効化が可能です。


[ブレンドモード]

パーツの表示属性を変更できます。
変更可能な属性は、乗算・スクリーン・覆い焼き(リニア)・焼き込み(リニア)・ピクセレートの5つで、PSDレイヤーに属性が設定されている場合は、インポート時に自動的に変更されます(ピクセレートを除く)

ピクセレートはモザイク効果です。選択するとパーツの表示部分に16x16ピクセルのモザイクが適用されます。
モザイク効果はパーツの重ね順を無視した上、全てのパーツに適用されます。

[ブレンドモード]

ピクセレートはwindowsSDKでのみ利用可能です。他SDKでは使用できませんので、ご注意下さい。


[パラメータリセット]

スクロールバーなどで一時変更したパラメータをリセットします。
但し、現在編集中のパーツのパラメータはリセットされません。

※ [HOME]キーでキーボードショートカットできます。


[直接数値入力]

レイアウト編集モードでは、編集可能なレイアウト数値は直接入力で設定する事が可能です。
尚、編集できない項目については表示されません。

直接数値入力

4-2.参照画像の登録・参照・削除

ツリー最上段の「参照画像一覧」を利用すると、
キャラクターのスクリーンショットや参考用のラフ画像などを保存し、
キャラクターに重ねて細部の比較ができます。

参照画像の登録・参照・削除

参照画像として登録できる画像形式は[.png]形式のみです。
外部から画像を登録する場合は、ツリーから参照画像番号を選択してドラッグ&ドロップします。
参照画像の表示をオンオフしたい場合は、参照画像一覧のアイコンをクリックするか、参照画像番号に対応した[数字キー(1~9)]でキーボードショートカットによるオンオフが可能です。
現在のキャラクター状態を参照画像として保存する場合は、 キーボードショートカット[CTRL + 数字キー(1~9)]で上書き保存が可能です。
登録した参照画像を削除したい場合は、参照画像番号を選択して編集画面のボタンから削除します。

参照画像の登録・参照・削除

参照画像の登録・参照・削除

4-3.パーツ位置・パーツ重なり順の調整

パーツ位置・パーツ重なり順の調整

パーツの位置や重なり順がおかしい場合は、基本的にはPSD画像を修正して再インポートする事で解消されますが、レイアウト調整で細かく調整する事もできます。


【レイアウト・Z座標の調整方法】

[パーツ編集](ツリー青背景部分)から、位置や重ね順を調整したいパーツの項目を開き、[レイアウト]または[Z座標]を選択します。

パーツ位置・パーツ重なり順の調整

基本編集画面に表示される「XY座標編集ポインタ」のドラッグまたは直接入力により、パーツの基本座標を調整することができます。

※ shift+ドラッグで垂直水平方向に動かせます

※[num1][num3]または[CTRL + num3][CTRL + num1]で、キーボードショートカット編集も可能です。

前髪とマブタや瞳の重ね順など、パーツの重ね順(Z値)を変更したい場合は、「Z座標編集バー」を上下にドラッグする事により、0.1単位で調整することができます。

※[num8][num2][num4][num6]または[CTRL]押しながらキー入力で、キーボードショートカット編集が可能です。


【レイアウト(回り込み調整)】

「耳L」「耳R」、または追加パーツの「胸揺れ」「頭部連動回り込み」「胴体連動回り込み」には、頭や身体の向き変更中に、詳細なZ座標調整が可能な項目があります。

耳の回り込み調整の場合は、[左]~[正面]~[右]のボタンが頭の左右向きの度合いを表しており、 それぞれの度合いごとにXY座標とZ座標を調整する事ができます。

レイアウト(回り込み調整

4-4.頭部・胴体角度の調整

頭部全体・胴体全体は、角度範囲を調整する事ができます。

頭部・胴体角度の調整

[頭部全体] - [XY座標角度(頭傾き)] 及び、[胴体全体] - [XY座標角度(身体傾き)]を選択し、編集画面に表示される「角度調整ポインタ」をドラッグすることで、左回転時、通常時、右回転時の角度と位置が設定できます(SHIFTを押しながらドラッグで、15度刻みの設定もできます)

※ [num7][num9]または[CTRL]押しながらで角度編集のキーボードショートカットが可能です


【状態ごとの角度編集】

状態ごとの角度編集

編集画面左上の、「XY座標角度」というボタンから「左」「正面」「右」を選択し、 角度のパラメータを最大まで左や右に傾けた状態として、それぞれ必要な角度に設定します。

状態ごとの角度編集

※ 「正面」状態の角度も編集する事ができます。
角度編集した状態でPSDを再インポートした場合は、自動的に角度補正してパーツを取り込み直します。
ただ、正面状態に角度をつけると、以後の向き変形全ての編集インターフェースに角度が付きます。
作業に支障が出る場合は、一度正面状態の角度を0に戻してから向き変形の編集を完了し、最後に元に戻す事を推奨します。

4-5.各パーツのメッシュ変形

各パーツのメッシュ変形

E-moteキャラクターの上下左右向きや髪などの揺れ形状は、「メッシュ変形」という変形手法の組み合わせで表現されています。

この項では、頭や体などを上下左右向きに動かすパラメータごとに、各パーツの変形度合いと位置調整を行います。 基本的には、[3.ポーズ詳細編集でテスト]で確認した、変形状態や変形時のパーツ位置がおかしい部分を修正してゆきます。

[パーツ編集]から変形度合いを変更したいパーツを選択し、それぞれの[メッシュ~]を選択します。 メッシュで調整できる項目は大まかに次のようになっています。

【向き系パラメータ】
  • [頭傾き] 頭を左右に傾けた際の変形
  • [頭回転・縦]  頭を上下に向けた際の変形
  • [頭回転・横] 頭を左右に向けた際の変形
  • [身体傾き] 胴体を左右に傾けた際の変形
  • [体回転・縦] 胴体を上下に向けた際の変形
  • [体回転・横] 胴体を左右に向けた際の変形
  • [特殊変形A] 特殊な変形を割り当てます。
  • [特殊変形B] (.ver3.8) 特殊な変形を割り当てます。特殊変形Aと異なり、4段階に変形が設定出来ます。
【振動系パラメータ】
  • [髪揺れ・縦] 髪が上下に揺れた際の変形
  • [髪揺れ・横] 髪が左右に揺れた際の変形
  • [髪揺れ・横弛み] 髪が左右に揺れた際、長い髪が弛む際の変形表現
  • [胸揺れ・縦] 胸が上下に揺れた際の変形
  • [胸揺れ・横] 胸が左右に揺れた際の変形
  • [パーツ揺れ・縦] アクセサリーや特殊なパーツが上下に揺れた際の変形
  • [パーツ揺れ・横] アクセサリーや特殊なパーツが左右に揺れた際の変形

【メッシュ変形・調整の作業】

調整したいメッシュ項目を選択し、前項で行ったようにそれぞれの上下左右ボタンを押すことで 変形時の状態とメッシュエディット枠が表示され、形状を調整することができます。

メッシュ変形・調整の作業


【メッシュ変形時のツール】

メッシュ変形・調整の作業

メッシュエディット枠上で右クリックをすると、 変形オプションの項目が表示され、以下の機能が使用できます。

※ [ ]内はキーボードショートカットです。


[テンプレート]

メッシュ変形の調整タイプが選べます。 基本は[マニュアル]または[パースペクティブ]です。


[クリア]

メッシュの変形情報をリセットします。[num0]


[微調整する]

微調整する

以下のようなメッシュ形状調整が使用できます。

  • 少し強調する [num3]
  • 少し抑制する [num1]
  • 少し拡大する [CTRL + num3]
  • 少し縮小する [CTRL + num1]
  • 右に少し傾ける [num9]
  • 左に少し傾ける [num7]
  • 左に少し移動する [num4]
  • 右に少し移動する [num6]
  • 上に少し移動する [num8]
  • 下に少し移動する [num2]
  • 左に移動する [CTRL + num4]
  • 右に移動する [CTRL + num6]
  • 上に移動する [CTRL + num8]
  • 下に移動する [CTRL + num2]

[形状を変形する]

形状を垂直・水平方向に反転させることが出来ます。


[コピーする]

メッシュ形状をクリップボードにコピーします [CTRL + C]


[ペーストする]

コピーした形状を今選択しているメッシュ変形にペーストします [CTRL + V]


【メッシュ情報のインポート・エクスポート】

メッシュ情報のインポート・エクスポート

ツリーの[パーツ編集]または[メッシュ(○○)」上で右クリックする事でメニューを開き、各パーツまたは全パーツまとめて、登録されたメッシュ情報をクリップボードにエクスポート及びインポートする事ができます。

エクスポートしたメッシュ情報は、テキストファイルなどに保存して、いつでも再インポートできます。

これで、メッシュ情報のバックアップを作成したり、汎用追加パーツの変形情報をライブラリとして保存しておく事が可能です。

※ 全てのメッシュ情報を一括エクスポートした場合でも、追加パーツのメッシュ情報は含まれません。 追加パーツの場合は、パーツごとの一括エクスポートが必要です。

これまでで説明した機能を使用して、キャラクター動作のおかしな部分を調整、修正してゆきます。以後に、調整作業の具体的手順を表記します。 基本的には、おかしな動きをするパーツを指定して、少しずつ調整してゆく手順となります。

メッシュ情報のインポート・エクスポート

メッシュ情報のインポート・エクスポート

メッシュ情報のインポート・エクスポート

4-6.目・涙の変形調整

目・涙の変形調整

目・瞳には3つの専用変形調整項目があります。

大雑把には操作する必要有りませんが、元テンプレートと極端にサイズや形状が異なるパーツなどで微調整が必要な場合に操作します。目L・目R別々に設定できます。


[メッシュ(瞳上下)][メッシュ(瞳左右)]

瞳の移動限界や移動角度を調整します。 たれ目やつり目のキャラクター用に、瞳を斜め方向に動かす調整もできます。あまり範囲ギリギリまで動かさないように調整した方が、綺麗に動作しやすいです。


[メッシュ(目・表情)]

目の開閉を調整します。なるべく滑らかにつながるようにすると、綺麗に動きます。
数値の推移は、以下のようになっています。
[-10]驚き-[0]通常-[5]半閉じ-[10]閉じ-[20]笑い閉じ [30]特殊1 [40]特殊2

メッシュ情報のインポート・エクスポート


[瞳位置調整]

目の開閉に伴う、瞳位置の微調整ができます。
目が閉じていく過程に合わせて位置を下げてゆくと綺麗に動きます。
また、特殊状態の目などで瞳のサイズが変化する場合にもこの調整を使用します。


[ハイライト位置調整]

瞳ハイライトを別パーツとして作成してある場合は、この項目が使用可能です。
目の閉じ加減にあわせて、瞳ハイライトの位置、形状を調整できます。
ハイライトは瞳の上下左右動きに影響されますので、 瞳から独立させたい場合は 追加パーツで[表情+目接着+目開閉同期」などを使用する必要があります。


[涙位置調整]

目の開閉に伴う、涙位置の微調整ができます。
基本状態では涙が表示されませんので、[涙表示]のスクロールバーを調整して、表示状態にしてから編集する必要があります。

涙位置調整


[涙追加○○調整]

psd側のレイヤー名[涙追加][涙追加L枠][涙追加R枠]で作製された、頬に伝うような涙の頭上下左右向き・目の開閉に対する位置と形状を調整できます。通常の涙と同様に、涙表示を操作して表示してから編集する必要があります。

4-7.口の変形調整

口の変形調整

[メッシュ(一括)][口(個別調整)]は、口(クチ)専用の変形調整です。
口は、開閉をシンプルに調整する「メッシュ(一括)」と、口の種類ごとに開閉パターンを個別調整する「メッシュ(個別選択)」を選択できます。基本的には一括で問題ありません。


[口] - [メッシュ(一括)]

[口] - [メッシュ(一括)]

会話時の口の開き具合を微調整できます。
「開きはじめ」は、「閉じ」状態から「開き」へ切り替わった直後の変形状態です。最も口が閉じているように形状を調整します。なるべく、下顎が動いているように変形を意識すると綺麗に動きます。

[口(個別調整)] - [メッシュ(○○)]

各口の表情ごとに開き方を個別設定できます。
設定の手順が特別で、先に[メッシュ(個別選択)]で設定したい口のパターンを選択し、ツリーの名称がグレーから黒に変わった[メッシュ(○○)]を選択しないと、個別編集ができません。

また、これら個別編集の口は、[メッシュ(一括)]の影響を受けます。 個別編集する場合は、[メッシュ(一括)]の開閉設定をクリアしてから編集する事を推奨します。

口の変形調整


[頭部]-[輪郭]-[メッシュ(口パク)]

口パクに合わせて輪郭(アゴ)を変形させる事もできます。
変形させすぎると顔の形状全体に影響が生じますので、注意が必要です。

4-8.眉の変形調整

眉の変形調整

メッシュ(眉・表情)]は眉L・眉R専用の変形調整項目です。
眉の変形は、最短経路を自動計算する機能を使用しており、通常・怒り・悲しみ・笑いで共通の経路を通りながら画像を切り替えて表情の変化を表現しています。
尚、特殊1と特殊2は独立していますので編集や調整の必要はありません。


[メッシュ(眉・表情)]

眉毛の変形推移を調整できます。
表情同士の推移構造は下図のようになっており、構造的に4つの「中間点」が近い形状になっているほど、綺麗に形状変化します。
単純な話、全ての眉に同じ画像を登録している場合であれば、中間点全て同じメッシュをコピーしてしまえば最も綺麗に形状変化するということです(その場合、それぞれの感情表現をメッシュ変形で作成します)
眉L・眉Rそれぞれ別々にメッシュ調整します。

[0]基準-[10]中間点(基準) ・ [11]中間点(怒)-[20]怒 ・ [21]中間点(哀)-[30]哀
[31]中間点(笑)-[40]笑-[49]基準移行 ・ [50]特殊1 ・ [60]特殊2

メッシュ(眉・表情)

4-9.鼻の変形調整

鼻の変形調整

[メッシュ(鼻切り替え)]は、鼻専用の変形調整項目です。 頭を左右に向ける際に、鼻筋のデザインを切り替える場合に使用します。

「左」「左切り替え」「正面」「右切り替え」「右」の5つの変形ポイントがあり、「左切り替え」「正面」「右切り替え」の形状をなるべく近づけることで滑らかに鼻のパーツが切り替わります。

鼻の影や、劇画タッチの鼻など、この機能だけでは表現しきれない場合は、 追加パーツで「表情+鼻接着+揺れなし」や、「頭部+頭部枠同期+頭部連動回り込み」などを使用します。

4-10.頭部全体枠・胴体全体枠の調整

鼻の変形調整

[頭部全体][胴体全体]は、4-3で紹介した頭や胴体の回転の他に、頭は胴体の動きに、胴体は頭の動きに影響を受けて変形する挙動が設定されています。

不要な場合はメッシュをクリアしてしまって問題ありませんが、正しく設定すると、キャラクターがより人間らしい自然な挙動をするようになります。

また、初期状態の女子正面テンプレートでは、頭部全体及び胴体全体の[メッシュ(特殊変形)]に、身体の前後移動を表現する変形が設定されています。

鼻の変形調整

これらは、斜め向きキャラクターやシンプルなキャラクターを作成する際には不要となりますので、メッシュ情報をクリア(num0)してしまう事を推奨します。

※ 頭部全体・胴体全体の編集項目に表示されている[XY座標(枠位置)]は、基本的に用途はありません。 PSDインポート時にのみ、ガイドとして使用する項目となっています。不用意に操作すると頭や体の中心軸がズレますので、ご注意下さい。

4-11.追加パーツの編集・削除

【追加パーツ順序編集】

追加パーツは、追加パーツ名をツリー上でドラッグする事で、順序を変更できます。

追加パーツ順序編集


【追加パーツを削除する】

追加パーツを削除する

一度追加した「追加パーツ」を削除したい場合は、各追加パーツの[追加パーツを削除する]を選択すれば ツリーごと削除することができます。 但し、削除してしまった追加パーツは、元に戻すことはできません
一時的に非表示化したい場合は、「パーツ無効化」を利用します。

4-12.パーツの手動インポート、エクスポート

E-moteLite2.4以前の機能として、パーツの手動インポート及びエクスポートができます。


【png形式でソースを手動インポート】

編集モードツリーから「ソース編集」を開き、更新したいパーツのページにpng形式でドラッグ&ドロップします。
追加パーツの場合も同様に、各追加パーツの項目から「ソース編集」を選択しインポートできます。
画像をインポートすると、自動的にそのパーツのメッシュ枠サイズが更新されます。

png形式でソースを手動インポート


【ソース画像のエクスポート】

ソース画像のエクスポート

「ソース編集」の各項目から、登録されているパーツをpng形式でエクスポートすることができます。
追加パーツも同様に、追加パーツツリー内の「ソース編集」からパーツをエクスポートできます。

4-13.特殊な機能

【属性カンプパネル】

(E-mote3.5正式版のみ使用可能)

現在の「パーツ無効化」状態を[属性カンプ]として保存し、名前をつけていつでも呼び出す事が出来る機能です。

属性カンプパネル

上に重なったパーツの陰に隠れて見えない部分や、アクセサリー差分を切り替えたときの見た目などを効率よく確認・編集が出来ます。また、無効化状態はキャラクターデータのエクスポート時にそのまま反映されますので、差分出力も容易となります。

属性カンプパネル

上記のメニューは、属性カンプ上右クリックのコンテキストメニューからも選択できます。

属性カンプパネル


【PSDを2つまとめてインポートする】

(E-mote3.5正式版のみ使用可能)

PSDを2つまとめてインポートする

親となるPSDデータに重ねて差分パーツのみのPSDデータをインポートし、少ない労力で別バージョンのキャラクターを作成する事ができます。使用するには幾つかの条件と手順が必要です。

[1.差分PSDの用意]

親となるPSDデータと、差分となるPSDデータを用意します。

差分PSDの用意

親PSDは、既にインポート済みのものを用意します。
追加パーツなど不要となるレイヤーは削除するか、レイヤー名を変えて読み込まれないようにしておきます。

差分PSDは、親と全く同じ画像サイズで、差分として登録したいレイヤーのみで構成します。
レイヤー名は通常と同様のルールで命名してください(前髪として差し替えたいなら、レイヤー名も「前髪」で) [2つまとめてインポート]では、親PSDと差分PSDで同じ名前のレイヤーが有った場合は、親PSDのレイヤーを無視して差分PSDのレイヤーをインポートします。

その他、頭部全体枠や胴体全体枠も更新したい場合は、半透明化しておくか、外枠だけの状態にしておくとインポート時の確認がし易くなります。

[2.インポート先mmoの準備]

インポート先のキャラクターデータ(mmo)から、アクセサリーなど、不要となる追加パーツは削除します。 プレーンな状態のキャラクターデータを用意してください。

[3.インポートする]

インポートする

ファイル]-[PSDを2つまとめてインポートする]を選択し、親PSD、差分用PSDの順にインポートします。
まとめてインポートする場合は、基本的に「Z値自動調整」は無効化します。有効化した場合は、差分用PSDに含まれるパーツが親PSDに重なっているものとしてインポートされます(全部手前に配置されます)

インポートする

※ 差分PSDでインポートされたパーツは、元々のメッシュ枠を引き継いでいる為、取り込み枠のリセットが必要です。全ての差分パーツの取り込み枠を確認して下さい。
全ての確認が終了したら、インポートを行います。

インポートする

インポートが完了したら、追加したパーツのZ値を調整して作業完了です。
以後テクスチャの修正などがあった場合も、2つのPSDで再インポートを行います。


【セレクタ定義】

(E-mote3.5対応テンプレート・3.5エディタのみ使用可能)

腕A~腕Eのfade制御を、眉や目などのような単体パラメータ制御に切り替える機能です。

セレクタ定義

ポーズ詳細編集]-[物理挙動編集]-[パラメター設定]-[セレクタ]にチェックを入れると適用されます。 (3.5基本設定ではONに設定されています)

セレクタ定義

3.4以前のテンプレートで腕差分を切り替える際は、「fade_aを非表示にして、fade_bを表示に~」といった複雑な手間が必要だったものを、arm_typeのパラメータを制御するだけのシンプルな構造になります。ただし、腕Aと腕Cと腕Dを同時表示するような特殊制御が出来なくなります。全て表示して編集たい場合は一旦セレクタ定義をOFFにし、属性カンプなどを利用して不要なパーツを非表示にするなどして編集して下さい。

セレクタ定義

※ セレクタ定義適用時の、腕差分への追加パーツの注意
セレクタ定義適用時のパーツ編集モードでは、選択されていない腕は非表示状態になり、腕以外のパーツの編集時は腕L 腕R 腕LA 腕RAが表示されます。 腕に追加パーツを使用したい場合は、腕の設定にあったfadeパーツを使用するか、一時的に腕セレクタをOFFにする必要があります。

セレクタ定義


【テンプレートミラー化機能】

[編集]より[ミラー化]を選択すると、テンプレートを左右反転して作成することが出来ます。

テンプレートミラー化機能

ミラー化したテンプレートは左右のパラメーターも逆転しますので、 通常のテンプレート同様にそのままキャラクター編集をすることができます。


以上で、キャラクターの調整・修正の手順及び機能の説明は終了となります。

3章で説明した不具合のチェックと、4章での調整作業を繰り返し、不具合を全て解決したならば、 次の[5.モーションの編集]以下の作業でキャラクターの仕草や表情組み合わせ作成してゆきます。


5.モーションの編集

本章からは、作成したキャラクターを実際にソフトウェア上で動かすためのポーズや表情の組み合わせ手順の説明、髪やアクセサリー、胸などの揺れパターンの設定を行ってゆきます。

E-moteは、キャラクターの表情やポーズを制御する「パラメータ」、パラメータを時間単位で遷移させる「タイムライン」という2つの仕組みから、リアルタイムで滑らかなキャラクターモーションを作成します。 これらの制御、作成には3章で簡易的に説明した「ポーズ詳細編集」の各ツールを用います。

モーションの編集

5-1.物理挙動編集

物理挙動編集」では、キャラクターの大まかな動作チェックや、挙動設定の保存、 作成したモーションの合成プレビュー等、ポーズ作成やモーション作成の重要な編集が行えます。

ここでは、サンプルタイムラインなどでキャラクターの挙動を確認しつつ、 「パラメータ設定」でキャラクターの向き挙動や揺れ挙動に関する設定をしてゆきます。

モーションの編集


[タイムライン(メイン)][タイムライン(差分)]

[タイムライン(メイン)][タイムライン(差分)]

「タイムライン編集」で作成したタイムラインを再生できます。
基本的な動作であるメインタイムラインと、副次的な動作(呼吸モーションや口パクなど)である差分タイムラインをそれぞれ選択する事で、2つを合成したアニメーションを再生する事も出来ます。

[タイムライン(メイン)][タイムライン(差分)]

尚、エディタ・動画出力機能上では2つのタイムラインまでしか合成できませんが、SDKを使用したソフトウェア上では3つ以上のタイムライン合成、及びタイムラインのフェードイン合成・フェードアウト合成など幅広い組み合わせ表現が可能となります。


【共通機能】

共通機能

以下のボタンと機能は、[パラメータ編集][物理挙動編集][タイムライン編集]といった3つの編集モード全てに共通しています。 ※ [ ]内は、キーボードショートカットです。

  • [パラメータリセット][home]
    変更された全パラメータをリセットします。 タイムラインが再生中の場合はそちらの動作が優先されます。
  • [パラメータコピー][CTRL + C]
    現在の全パラメータ設定をクリップボードにコピーします。
  • [パラメータペースト][CTRL + V]
    クリップボードのパラメータ設定をペーストします。 タイムライン再生中の場合は、そちらが優先されます。
  • [カタログへ追加][CTRL + B]
    現在の全パラメーター設定を、パラメータセットとして「カタログ」へ追加します。(カタログについては、後述を参照)
  • [カタログから読込][CTRL + N]
    「カタログ」を開き、登録されたパラメータセットをフレームにペーストします。

【プレビュータブでの使用可能機能】

プレビュータブで変更した以下の設定は、キャラクターデータには保存されません。

プレビュータブでの使用可能機能

  • [メッシュ分割率]
    メッシュ分割率を変更した際の挙動を確認できます(基本値は1です)

    メッシュ分割率は0に近づくほど動作が軽くなりますが、その分変形が大雑把になりますキャラクターを使用するプラットフォームに合わせて、最適なメッシュ分割率の確認が必要です。

  • [キャラ位置上下]~[Z表示]
    向きや表情、表示のオンオフを変更した際の挙動を確認できます。

  • [遷移フレーム]
    現ポーズから別ポーズへ移行する際にかけるフレーム数を調整できます。15が標準。0で中割り無しとなります。
  • [遷移イージング]
    ポーズ移行する際の加速度を調整できます。[-]で減速しつつ遷移、[+]で加速しつつ遷移となります。

  • [髪揺れスケール][パーツ揺れスケール][胸揺れスケール]
    それぞれのパーツが揺れる際の、揺れ幅スケールをプレビューできます。
    1が標準、0で揺れ幅無し、3で揺れ幅最大となります。
    揺れスケールは、値を小さくするとキャラが大きく動いても揺れ幅は小さくなります。
    逆に値を大きくすると揺れ幅は大きくなりますが、すぐに最大値に達して最大状態のまま固まってしまいます。

  • [風強度]
    [風]のパラメーターを追加した際の挙動を確認できます。


【パラメータ設定タブでの使用可能機能】

パラメータ設定タブでの使用可能機能

パラメータ設定タブで変更した設定は、 キャラクターデータごとに個別に保存されます。

  • [円形クランプ]
    各部分を上下左右に変形させる際に、四角を描くか、円を描くかを設定できます。大まかには、クランプをOFFでアニメ的に、クランプONで3Dモデル的に動くようになります。

  • [まばたきタイプ]
    キャラクターが瞬きする頻度と速度をプリセットの中から選択できます。

  • [物理モデル設定]
    キャラクターの各部分の重さ・硬さ・動きの滑らかさをプリセットの中から選択できます。

    プリセットモデルには、以下のようなものがあります。

    • 標準                
      全ての中間値で、基本となるモデル。

    • ふんわり                
      重量が軽く、上下左右の抵抗が大きく、ゆっくりと落ちてきます。

    • さらさら                
      重さは軽いですが、左右の抵抗が少なく伸びもあり、よく揺れます。

    • がっちりハード        
      殆ど伸びず、すぐに元に戻ろうとします。

    • 鉄の鎖                
      まったく伸びません。とても重く、下に垂れ下がりますが、左右には柔らかく揺れます。

    • ゴムひも                
      とてもよく伸びますが、跳ね回ってなかなか止まりません。

    • 無重力                
      重さがほとんどありません。一度動くと、逆方向に引っ張られるまでほぼ戻ってきません。

    • ふらり                
      本体が大きく動いても、ささやかな程度にしか揺れません。

    • ゆさり                
      一度だけ大きく揺れ、元に戻ります。

    • ぽよん                
      上下に多く揺れます。左右にはあまり揺れません。

    • ゆさゆさ                
      ゆっくりと何度も、特に左右に多く揺れます。

    • ぼよよん                
      全方位にゴムまりのように揺れまくり、よく伸び、なかなか止まりません。

※ 上記モデルのほかに、幾つかバージョン違いがプリセットされています。


以上、キャラクターの特徴に合わせてそれぞれの項目を設定し、 物理挙動設定を完了とします。

5-2.パラメータ編集・カタログ編集

「パラメータ編集」でキャラクターの向きや表情のパラメータを操作し、様々なポーズを作成する事ができます。
作成したポーズや表情は、[カタログへ追加]ボタンによって、[パラメータセット]として編集、保存する事ができます。

パラメータ編集・カタログ編集

[名前の変更]

サムネイルの名前をクリックすると、パラメータセット名称を変更することが出来ます。

[順番の変更]

サムネイルをドラッグする事でパラメータセットの順番を変更することが出来ます。

[削除]

[x]ボタンをクリックすることでカタログからパラメータセットを削除することが出来ます。

カタログに登録した「パラメータセット」は、後述の「タイムライン編集」にてキャラクターの動きを作成する際のパーツとして読み込むことができます。

尚、カタログから読み込む際には、チェックボックスのオンオフによって必要なパラメータだけを抽出して読み込むことができます。

パラメータ編集・カタログ編集

5-3.タイムライン編集

キャラクターの表情・向きの組み合わせを時系列的に編集できるモードです。
ツリーの[タイムライン編集]上で右クリック、または「新規タイムライン」ボタンを押すことで、 新たなタイムラインが生成され、編集ができるようになります。

タイムライン編集

※ タイムライン名は、ソフトウェア上で「動き」を再生する為の呼び出し名として使用されます。


【タイムラインの概念】

タイムラインの概念

タイムラインの概念

タイムラインは水色から青色のバーを1つの「動き」と考えます。

水色は1つ前のパラメーター100%、▲印の青色は設定したパラメーター100%状態です。 これらの区切りをキーフレームと呼び、目・頭・体・表情ごとに組み合わせ、並べることで「動き」のセットを作り出します。 左から右への流れは時間の経過を表す[フレーム]と呼び、1目盛りで[1/60]秒となります。

尚、フレーム0の状態は、このタイムラインを再生する前のポーズ・表情状態となります。
(エディタ上では、全パラメータリセット状態として設定されています)

※ 他ムービー作成ツールなどのタイムラインの仕組みとは、異なる特殊なものと認識して下さい。


【パラメータの編集項目】

時間軸に合わせてコピーしたり取り込んだりしながらキャラクターの表情や向きを編集し、 1つの「動き」を作成する事ができます。

タイムラインの概念

[再生/停止] [enter]

タイムラインで設定したモーションを再生または停止します。

[ポーズ/レジューム] [space]

モーション再生中に一時停止します。

[動画を出力する] [ctrl+P]

作成したタイムラインセットをwmv形式または連番png形式で出力します。
出力の際には、画像サイズ・スケール(動画の倍率)・合成する差分タイムライン・動画終了までの動作余韻を選択できます。

動画を出力する

[カタログから読込] [ctrl+N]

「カタログ」を開き、登録されたパラメーターセットをフレームにペーストします。
カタログ上部のチェックボックスで、読み込みむパラメーターのON/OFF選択することが出来ます。

[差分用途]

チェックボックスをオンにすると、物理挙動編集でタイムライン(差分)としてプレビューできるようになります。 逆に、タイムライン(メイン)には表示されなくなります。

差分用途化して黄色くなったキーフレームは、タイムライン合成した際に正常に動作します。
青表示のままのキーフレームは、合成した際に異常動作をする可能性があります(主に表情遷移は異常動作をします)

[値]

各パラメーターの値です。変更する事で表示内容が変化します(矩形選択での一括変更可能)
右側半透明の数値が開始状態の数値、左側が終了時の数値となります(水色から青色へ変化)

[遷移イージング]

値が水色から青色へ移行する際の変化を減速的にするか加速的にするかを決定します。
[-]で減速しつつ遷移、[+]で加速しつつ遷移となります。


【ループの設定】

「ループ」のフレーム上で右クリックすると、 繰り返し動作に関するメニューが出現します。

ループの設定

[ループの始点を設定する]

繰り返し再生の始まりを設定します。

[ループの終点を設定する]

繰り返し再生の終了を設定します。このフレームから始点へ戻り繰り返します。

[最終フレームを設定する]

モーションを強制的に終了するフレームを設定します。


【キーフレーム編集】

複数フレームをマウスドラッグまたは[shift]+カーソルキー操作で、 キーフレームを矩形選択する事が出来ます。
選択した範囲を[ctrl]+マウスドラッグまたは[ctrl]+カーソルキー操作で、 キーフレームを矩形移動する事が出来ます。
各パラメーターのフレーム上で右クリックすると、フレーム編集に関するメニューが出現します。
この項目から、WAVファイルの波形データを取り込んで音声に対応した口パクを自動定義することが出来ます。

キーフレーム編集

[フレームを削除する]

カーソル範囲内に設定されたフレームを削除します。(Delete)

[フレームを分割する]

フレームを終点と始点に分割します。パラメーターの設定は分割前の設定を引き継ぎます。(Insert)

[全選択]

指定したフレームを0フレームから末尾まで選択します。(ctrl+A)

[WAVファイルから値を取り込む]

WAVファイルから1/60秒ごとの波形を読み取り、最低0最大5として自動読み込みします(音声再生はできません)

[キーフレームコピー&ペースト]

[ctrl+C]で選択範囲のキーフレームをコピー、[ctrl+V]でキーフレームをペーストする事が出来ます。
キーフレームをコピー&ペーストする際は、コピーしたい範囲よりも1フレーム後ろまでを選択する必要があります。

キーフレームコピー&ペースト


【タイムラインセットの編集】

左ツリー上の「タイムラインの編集」または作成したタイムライン名の上で右クリックすると、タイムラインセットの編集に関するメニューが出現します。

タイムラインセットの編集

※ タイムラインセットはドラッグで順序入れ替え、[shift]または[ctrl]を押しながら複数選択が可能です。

[名前を変更する] [F2]

名前を変更することが出来ます。

[タイムラインを複製する]

タイムラインセットをコピーします。

[タイムラインを削除する] [delete]

タイムラインセットを削除します。複数タイムラインを選択した場合は、一括削除が可能です。

[タイムラインを左右反転する]

タイムラインの左右方向パラメーターを反転します。ミラー化などでテンプレート反転させた時などに使用します

[タイムラインをJSONファイルへエクスポートする] (.ver3.8)

タイムラインの情報をjson形式ファイルで出力します。

[タイムラインをJSONファイルからインポートする] (.ver3.8)

タイムラインの情報をクリップボードへコピーします。データはテキスト形式などで保存出来ます。

[すべてのタイムラインをJSONファイルへエクスポートする] (.ver3.8)

ツリー上全タイムラインの情報をjsonファイルで出力します。 ※ [タイムライン編集]の上で右クリックしたときのみ選択できます。


[タイムラインをまとめてアニメーションカタログを作る]

(E-mote3.5正式版のみ使用可能)

タイムラインをgif動画化し、スクリプト作成の目安となるアニメーションカタログをhtml形式で生成する機能です。
複数のタイムラインを選択したときのみ、右クリックのコンテキストメニューから選択できます。

タイムラインセットの編集

[幅] [高さ] [スケール]

複数のgif動画を一括表示しますので、出力動画のサイズは150x150程度を推奨します。

[埋め込みテキスト]

入力欄に[%t]を入力する事でgif動画の名称をタイムライン名に置換してカタログに表示します。

[%f]を入力した場合は、プロジェクトのファイル名に置換されます。
[%f %t]併用で、そのままタグ形式として利用する事も可能です。

動画出力画面で[OK]を選択する事で、htmll形式のアニメーションカタログが生成されます。

埋め込みテキスト

ブラウザがInternet Explorerの場合、サムネイルをクリックするとキャプションがクリップボードにコピーされます。

以上で、タイムライン編集の説明は終了となります。

タイムラインは、キャラクターデータをソフトウェア上で動作させる際に、モーションを再生させるための呼び出し名となります。
ソフトウェア上での操作の詳細は、正式版エディタ同梱の各SDK対応リファレンスマニュアルをご参照下さい。


6.保存・スケール変換・各プラットフォーム用エクスポート

以上の手順で作成したモーションを、mmo形式で保存する事ができます。

保存・スケール変換・各プラットフォーム用エクスポート

キャラクターデータの保存には、[ファイル]より、以下の項目を選択することが出来ます。


7.キャラクターの再生

エクスポートしたキャラクターファイルを再生する際は、弊社からご提供するSDKをお客様のプログラムに組み込んでいただき、E-mote motioneditor の吐き出した専用データ(.psbなど)をライブラリに渡して一定の呼び出し手続きを踏むことで、描画処理を行なっていただく事になります。

SDKには、描画を制御するドライバに加え、口・眉・目などの表情の変化を補完し、胸の揺れや髪の揺れを自動計算する物理計算層が実装されております。

従ってお客様の方では「キャラクタの表示座標・表情・目の角度を指定」または「作成したタイムライン名を指定」「タイムラインA再生中にタイムラインBを合成再生」といった一般的なアドベンチャーゲームのスクリプトと同様の指定方法のみで、E-moteの動的な挙動を実現していただけるようになります。

尚、プラットフォームごとの利用方式につきましては、各固有ファイルに同梱されているリファレンスマニュアルをご参照頂ければ幸いです。

キャラクターの再生


8. 利用時のロゴ表記

E-moteをご採用頂いた際の、表記用ロゴ及びクレジットへの表記例を公開しております。

【E-mote公式ロゴ】

E-mote公式ロゴ

【クレジットへの表記例】

表記例1

[ Powered by E-mote. Copyright © M2 Co.,Ltd. all rights reserved. ]

表記例2

[ Copyright © M2 Co.,Ltd. all rights reserved. ]


9.新機能・機能更新

以下に、ver3.5以降で新たに追加された機能を紹介致します。

9-1.ver3.5.6追加機能

【涙・頬のビュー機能】

涙・頬のビュー機能

ver3.6以降のテンプレートでは[○○表示]のスクロールバーを操作し、涙・頬の差分を表示しながらのメッシュ調整が可能となります。


【分割サイズの設定】

分割サイズの設定

エクスポート時の設定により、テクスチャを小さく分割しテクスチャを効率よく格納する事が出来るようになりました。テクスチャのファイルサイズが圧縮されますが、展開時の負荷が増加します。


【テクスチャパッキング確認の追加項目】

分割サイズの設定

[ファイル]-[テクスチャパッキングを確認する]の項目に、新たに分割サイズ・差分パーツ毎のパッキング状態の確認が追加されました。

9-2.ver3.6追加機能

【バッチコンバート】

バッチコンバート

複数のデータを一括して出力する事が出来ます。
エディタに何もデータを読み込んでいない状態で、[ファイル]-[バッチコンバートする]を選択します。

バッチコンバート

基本的な設定は、通常のエクスポートと同様ですが、他に以下の機能が使用可能です。

[入力フォルダ] [出力フォルダ]

入力フォルダに保存されいるmmoファイル全てを指定形式に変換し、出力フォルダへ出力します。

[出力拡張子]

出力されるファイルの拡張子名を選択できます。

[パッキング]-[全差分を出力]

項目にチェックを入れると、出力時に「頭部」や「胴体」「タイムライン」「各種差分など」 分割エクスポート対応したデータ全てを別々に出力します。


【複数タイムライン選択・一括エクスポート】

複数タイムライン選択・一括エクスポート

複数のタイムラインを[ALT]+クリックで選択し、ドラッグで移動や、 右クリックメニューからクリップボードに一括でエクスポート出来ます。


【E-moteエディタの複数同時出力】

E-moteエディタの複数同時出力

スタートメニューのプログラム一覧から、ALTを押しながらE-moteアイコンをクリックすることで、E-moteエディタを複数同時起動できます(但し、windows8.1など、OSのバージョンによっては同時起動できない場合があります)


【出力データのグレースケール化】

出力データのグレースケール化

エクスポート時の設定から、出力データをグレースケール化する事ができます。
[変換]-[グレー化]の値を調節して、グレースケール化の度合いも調整可能です。


【動画出力設定の新機能】

動画出力設定の新機能

動画出力設定に以下の新たな機能が追加されました。

[ループの両端を接続]

ループ設定したタイムラインの始点と終点の状態を自動調整し、滑らかなループ動画を出力します。

[ピクセレートピクセル数]

ピクセレートピクセル1コマのサイズを[8pix]~[256pix]の範囲で設定できます。

9-3.ver3.8新規追加機能

【Zバイナリエディタ】

スタートメニュー/m2tools CheeseWareから、E-moteEditor(Z)を選択できます。

Zバイナリ版エディタは、β版ですが64bitOS環境限定で通常版E-moteエディタよりも大量のメモリを使用できるモードです。大きな画像やイベントシーン作成に活用下さい。また、機能が大幅に増えた3.8テンプレートの利用にも推奨しています(E-moteMovieMaker・えもふりでもZバイナリエディタは使用できます)

※ 2016年12月にリリースされたE-mote3.8テンプレート及びE-moteVRテンプレートは、 Zバイナリエディタの利用を推奨しています。

ノーマル版エディタの場合はインポート時にメモリが不足する可能性がありますのでご注意下さい。

Zバイナリエディタ


【動画出力設定の保存】

動画出力設定をローカルに保存できるようになりました。
[コンフィグ]より、保存した設定を呼び出したり、現在の設定の上書きがができます。

動画出力設定の保存


【タイムライン・フォルダ分類機能】

タイムラインをフォルダで整理出来るようになりました。[タイムライン編集]で[新規フォルダ作成]ボタンを押すか、または[タイムライン編集]にカーソルを合わせて右クリックで作成メニューを表示できます。

タイムライン・フォルダ分類機能

タイムライン・フォルダ分類機能


【タイムライン出力形式の変更】

タイムラインを[.json]というE-moteタイムライン専用形式でエクスポート・インポート出来るようになりました。前述のタイムラインフォルダの構造込みでも出力可能です。

タイムライン出力形式の変更

※ ver3.7以前のキャッシュへのコピー機能で.txtなどに保存したタイムラインは、そのままではインポートできなくなります。 但し、txt形式であれば、拡張子を.jsonに書き換える事で古いタイムラインもインポート可能です。(尚、UTF-8N以外の文字コードで保存されたtxtデータは、タイムライン名などが正常にインポートされません。UTF-8N形式で保存し直して下さい)


【サンプタイムラインのダウンロード】

E-moteForum・サンプルタイムラインダウンロードページにて、キャラクター性別・性格別のサンプルタイムラインを公開しています(随時更新)
3.8用json形式で必要に応じてダウンロード、インポートして活用できます。
(3.8用タイムラインは3.7以前のエディタではインポートできません)

サンプタイムラインのダウンロード


【新たな追加パーツ・機能追加された追加パーツ】

(E-mote3.8以降テンプレート・Zバイナリ版エディタ/64bitOS環境のみ)

ver3.8テンプレートより、新たな追加パーツが使用可能となりました。
[2-8.追加パーツタイプの設定]-[パーツ位置と追加パーツタイプ]の各項目をご参照下さい。

新たな追加パーツ・機能追加された追加パーツ


【瞳・マブタ・眉・クチの特殊変形設定】

(E-mote3.8以降テンプレート・Zバイナリ版エディタ/64bitOS環境のみ)

マブタ・瞳・眉・クチの形状を、微調整出来るようになりました。

瞳・マブタ・眉・クチの特殊変形設定

各表情パーツに、特殊なメッシュ変形を追加する事が出来ます。

通常の表情変化と組み合わせる事で、「微妙に怒っている目」や、「笑っているけどクチの端が怒っている」「点のようになった瞳」などの微妙な表現が可能となります。

瞳・マブタ・眉・クチの特殊変形設定

各パーツ毎に、[特殊A]~[特殊F]まで、6種類の変形を登録する事が出来ます
(尚、各[中間点(x)]は通常状態への遷移形状となりますので、基本的に変形はしないで下さい)


【VR表示用足データ】

(E-mote3.8以降テンプレート・Zバイナリ版エディタ/64bitOS環境のみ)

E-mote3.8テンプレートでは、E-mote VRで立体表示する為の専用足データが編集できます。

基本的な構造については、E-mote3.8用テンプレートに[e-mote38基本テンプレート(正面VR).psd]をインポートする事で確認できます。

VRキャラクター専用の項目として、以下の変形情報が編集できます。

[VR左右]
カメラがキャラクターの左右に回り込む際の、足の組み換え動作を作成します。

[VR上下]
カメラが基準の高さに対して上下に移動した際の、 アングルの変化(パースによる変形)を作成します。

VR表示用足データ

※ VR用キャラクターデータは、通常の上下左右向きアングルに加え、カメラの視点を原点とした特殊な構図で原画を作成する必要があります。具体的な構造・構図については、公開されているサンプルデータと仕様書をご参照下さい。


【キャラプロファイルの設定】

(E-mote3.8以降テンプレート・Zバイナリ版エディタ/64bitOS環境のみ)

E-mote3.8テンプレートでは、VRその他で活用する為の、各種メタデータを“物理挙動編集”>”キャラプロファイル”タブから設定する事ができます。
これらの値を適切に設定すると、SDK側でE-moteキャラの表示サイズをアプリの座標系に合わせて適切に設定することが可能になります。
エクスポート時にスケールをどのような値に設定しても表示時に補正をかけられるので、キャラ単位でのデータ容量の最適化がより容易に行えるようになります。

キャラプロファイルの設定

  1. 身長の数値を直接入力して下さい。
  2. “頭頂”、”目”、”口”、”胸”、”足元”それぞれのバーをD&Dで上下に動かして高さを設定して下さい。
     それぞれ身長から自動的に計算された相対的な数値が設定されます。
  3. 緑色の枠”バウンズ”(最大表示領域)のサイズをD&Dで設定して下さい。

※ これらのデータを参照・利用する方法は、別途開発者向けのドキュメントやサンプルをご参照下さい。


以上で、E-moteモーション作成マニュアルは終了となります。

ご不明な点・作製テクニックなどに関しましては、FAQまたは、E-mote Forumをご参照下さい。
今後とも有限会社エムツー並びにE-moteをどうぞ宜しくお願い申し上げます。


付録

E-mote基本テンプレート パラメータ対応表(ver3.8対応)

表情用基礎パラメータ

face_eye_LR (-30~+30) 瞳の左右位置

face_eye_UD (-30~+30) 瞳の上下位置

face_hitomi_sp 瞳形状の特殊調整(.ver3.8)

  • 00(通常)
  • 05(特殊A)
  • 10(特殊B)
  • 15(特殊C)
  • 20(特殊D)
  • 25(特殊E)
  • 30(特殊F)

face_eye_open 目の表情定義

  • -10(驚き)
  • 00(基準)
  • 05(半閉じ)
  • 10(閉じ)
  • 20(笑い閉じ)
  • 30(特殊1)
  • 32(特殊2)
  • 34(特殊3)
  • 36(特殊4)
  • 38(特殊5)(.ver3.8)
  • 40(特殊6)(.ver3.8)

face_eye_sp マブタ形状の特殊調整(.ver3.8)

  • 00(通常)
  • 05(特殊A)
  • 10(特殊B)
  • 15(特殊C)
  • 20(特殊D)
  • 25(特殊E)
  • 30(特殊F)

face_eyebrow 眉の表情定義

  • 00(通常)
  • 20(怒り)
  • 30(哀しみ)
  • 40(笑い)
  • 50(特殊1)
  • 51(特殊2)
  • 52(特殊3)
  • 53(特殊4)
  • 54(特殊5)(.ver3.8)
  • 55(特殊6)(.ver3.8)

face_eyebrow_sp 眉毛形状の特殊調整(.ver3.8)

  • 00(通常)
  • 05(特殊A)
  • 10(特殊B)
  • 15(特殊C)
  • 20(特殊D)
  • 25(特殊E)
  • 30(特殊F)

face_mouth クチの表情定義

  • 00(通常)
  • 10(怒り)
  • 20(哀しみ)
  • 30(笑い)
  • 40(特殊1)
  • 42(特殊2)
  • 44(特殊3)
  • 46(特殊4)
  • 48(特殊5)(.ver3.8)
  • 50(特殊6)(.ver3.8)

face_mouth_sp クチ形状の特殊調整(.ver3.8)

  • 00(通常)
  • 05(特殊A)
  • 10(特殊B)
  • 15(特殊C)
  • 20(特殊D)
  • 25(特殊E)
  • 30(特殊F)

face_eye_hi 瞳ハイライトの表示パターン

  • 0(ハイライト通常)
  • 1(ハイライト予備1)
  • 2(ハイライト予備2)
  • 3(非表示)

face_tears 涙の表示パターン

  • 0(涙無し)
  • 1(涙1)
  • 2(涙2)

face_cheek 頬の表示パターン

  • 0(頬1)
  • 1(頬2)
  • 2(頬3)
  • 3(頬4)
  • 4(非表示)

face_talk 口の開閉度合い(音量自動対応可)

  • 0(無音)
  • 1(開き始め)
  • 3(開き途中)
  • 5(最大音量)

頭部用基礎変数

  • head_LR (-30~+30) 頭の左右位置
  • head_UD (-30~+30) 頭の上下位置
  • head_slant (-30~+30) 頭の左右角度

胴体用基礎変数

  • body_LR (-30~+30) 胴体の左右位置
  • body_UD (-30~+30) 胴体の上下位置
  • body_slant (-30~+30) 胴体の左右角度

全体用基礎変数

  • act_sp (-30~+30) 特殊変形A
  • act_sp2 (-30~+30) 特殊変形B(ver3.8)
  • act_sp3 (-30~+30) 特殊変形C(ver3.8)
  • move_LR (-30~+30) キャラクター全体の左右位置
  • move_UD (-30~+30) キャラクター全体の上下位置

腕差分表現用基礎変数

  • arm_type (0 ~ 4) 腕A~腕Eのセレクタ制御用
    (セレクタON時のみ使用可能)
  • fade_a (0 ~ 1) 腕LA・腕RAの表示非表示
  • fade_b (0 ~ 1) 腕LB・腕RBの表示非表示
  • fade_c (0 ~ 1) 腕LC・腕RCの表示非表示
  • fade_d (0 ~ 1) 腕LD・腕RDの表示非表示
  • fade_e (0 ~ 1) 腕LE・腕REの表示非表示
    (セレクタOFF時のみ使用可能)
  • fade_q (0 ~ 1) 差分用追加パーツvの表示非表示(ver3.8)
  • fade_r (0 ~ 1) 差分用追加パーツwの表示非表示(ver3.8)
  • fade_s (0 ~ 1) 差分用追加パーツxの表示非表示(ver3.8)
  • fade_t (0 ~ 1) 差分用追加パーツyの表示非表示(ver3.8)
  • fade_u (0 ~ 1) 差分用追加パーツzの表示非表示(ver3.8)
  • fade_v (0 ~ 1) 差分用追加パーツvの表示非表示
  • fade_w (0 ~ 1) 差分用追加パーツwの表示非表示
  • fade_x (0 ~ 1) 差分用追加パーツxの表示非表示
  • fade_y (0 ~ 1) 差分用追加パーツyの表示非表示
  • fade_z (0 ~ 1) 差分用追加パーツzの表示非表示

VR専用変数(ver3.8)

  • vr_UD (-30~+30) VRカメラ高さによる変形
  • vr_LR (-30~+30) カメラ左右回込みに対する変形

physice自動対応項目(プログラマ・スクリプタ用)

  • bust_LR(-30~+30) 胸揺れ左右方向
  • bust_UD(-30~+30) 胸揺れ上下方向
  • bust_LR_spare(-30~+30) 胸揺れ(予備)左右方向
  • bust_UD_spare(-30~+30) 胸揺れ(予備)上下方向
  • hair_LR_front(-30~+30) 前髪揺れ左右方向
  • hair_LR_M_front(-30~+30) 前髪揺れ弛み左右方向
  • hair_UD_front(-30~+30) 前髪揺れ上下方向
  • hair_LR_sideL(-30~+30) 横髪L揺れ左右方向
  • hair_LR_M_sideL(-30~+30) 横髪L揺れ弛み左右方向
  • hair_UD_sideL(-30~+30) 横髪L揺れ上下方向
  • hair_LR_sideR(-30~+30) 横髪R揺れ左右方向
  • hair_LR_M_sideR(-30~+30) 横髪R揺れ弛み左右方向
  • hair_UD_sideR(-30~+30) 横髪R揺れ上下方向
  • hair_LR(-30~+30) 後髪揺れ左右方向
  • hair_LR_M(-30~+30) 後髪揺れ弛み左右方向
  • hair_UD(-30~+30) 後髪揺れ上下方向
  • quake_LR(-30~+30) その他のパーツ揺れ左右方向
  • quake_LR_M(-30~+30) その他のパーツ揺れ弛み左右
  • quake_UD(-30~+30) その他のパーツ揺れ上下方向
  • quake_LR_spare(-30~+30) その他揺れ(予備)左右方向
  • quake_LR_M_spare(-30~30) その他揺れ(予備)弛み左右
  • quake_UD_spare(-30~+30) その他揺れ(予備)上下方向