えもふりチュートリアル

(えもふりver3.9対応)

.ver 20180109

はじめに■

本チュートリアルは、「E-moteがはじめて」という人に向けた入門用チュートリアルです。

■1.~■5.の手順通りに作業する事で、手軽に動画の作成ができてしまいます!

1体作る事でE-moteの構造理解もできますので、是非チャレンジしてみて下さい。

E-moteの詳しい使い方について知りたい場合には、マニュアルサイトをご参照ください

尚、本マニュアルで解らないことがありましたら、E-mote公式Forumをご参照、お問い合わせ下さい。

■■index■■

えもふりチュートリアル

はじめに

1.psd画像を用意しよう!

2.作ったキャラクターをE-moteに登録しよう!

3.キャラクターの細部を調整しよう!

4.動かしてみよう!キャラクターを出力しよう!

5.追加パーツを使ってみよう!

おわりに

付録


1.psd画像を用意しよう!

この項では、E-moteシンプルテンプレートに読み込ませるため、
5つの体用パーツと、4種類8つの表情用パーツを作成します。

まず、E-moteシンプルテンプレートに取り込む[psd画像]を準備するために、
PhotoShopClipStudioSAIなど、psd形式のファイルが使用できるツールを用意して下さい。

初めての方は、シンプルテンプレート正面タイプか、シンプルテンプレート微斜めタイプをベースにするのがおすすめです。


1-1.まず、下書き(元絵)を用意しよう!

えもふりで動かしたいイラストの下書きを用意して下さい。

画像のサイズは、[シンプルテンプレート_正面タイプ基本画像.psd]の
キャラクターと同程度の1200pix1100pixにします。

※ 本文中の[レイヤー名]や作成する画像で不明な点がありましたら、シンプルテンプレートに同梱されいてる「シンプルテンプレート_正面タイプ基本画像.psd」を参考にして下さい。

えもこのワンポイント!

 

えもふりでは、最大で縦2048pix、横2048pixのpsdが読み込めるよ!

そしてE-mote正式版なら、なんとサイズは無制限!

 

あと、描き方が良く分からない人は、テンプレートと一緒に入っている[シンプルテンプレート_プレーン画像.psd]を使ってみてね!レイヤー名が元からついているから、そのまま描き込めるよ!


1-2.目を描こう!

目は、輪郭線(上下マブタ)・瞳・白目部分をそれぞれ別のレイヤーに描きます。
目は、輪郭線(上下マブタ)・瞳・白目部分をそれぞれ別のレイヤーに描きます。
・瞳は、マブタで隠れる部分もしっかり描いて下さい。 (マブタからはみ出しても構いません)

・白目部分は、あとで瞳を切り抜くためのガイドにもなりますので、 しっかり瞳の裏まで塗りつぶします。

描けたら、それぞれのレイヤー名を、下図のように[マブタ通常][瞳通常][白目通常]と設定してください。

・白目部分は、あとで瞳を切り抜くためのガイドにもなりますので、 しっかり瞳の裏まで塗りつぶします。

 

えもこのワンポイント!

このチュートリアルでは説明上、目から描いているけれど、

自分の描きやすいところから描いてオッケーだよ!

「それと、E-moteはpsdのフォルダ名もパーツ名として読み込んで、自動で合成できるんだ。

それと、右目と左目は両方とも1つのレイヤーに描いてね!別々に描く必要は無いよ!
E-moteはpsdのフォルダ名もパーツ名として読み込んで、自動で合成できるんだ。だから「瞳通常」のフォルダの中に瞳の色や塗りを入れておけば、後で自由に修正出来るんだよ!
すごいね!


 

1-3.閉じている目も描きます。

閉じている目を描きます。
少し笑い気味の目にすると、後で動かした時に仕草が可愛くなりやすいです。
マブタ閉じ

描けたら、レイヤー名を[マブタ閉じ]と設定しましょう。
描けたら、レイヤー名を[マブタ閉じ]と設定しましょう。


1-4.眉を描こう!

いちばん普通な状態の眉を、左右1組描きます。
喜怒哀楽で言えば、「楽」にあたる眉です。
眉

描けたら、レイヤー名を[]と設定します。
眉レイヤー

えもこのワンポイント!

シンプルテンプレートではこの眉を色々変形させて感情を表現するけど、ベーシックテンプレートではもっとたくさんの眉の描き分けや登録が出来るよ!

なんと、瞳のハイライトや髪の下の眉の影も別々につくれるんだよ!

 


1-5.鼻を描こう!

鼻を描きます。
鼻
鼻レイヤー

描けたら、レイヤー名を[]と設定します。

えもこのワンポイント! レイヤーの透明部分に小さなゴミとかがあると、
それもパーツの一部として取り込んじゃうから注意してね!透明部分に消し残しや小さなゴミが残っていないかチェック!

1-6.クチを2つ描こう!

閉じているクチと、開いているクチの2種類を描きます。
クチ

クチレイヤー

描けたら、それぞれのレイヤー名を[クチ][クチ開き]と設定します。

ここまで、8枚の画像が用意出来ていれば、表情パーツの作成は終了です!

えもこのワンポイント!

クチは、漢字の口ではなくカタカタで「クチ」とレイヤー名を付ける事に注意!

それと、レイヤフォルダでまとめる時は[クチ]ではなく[クチまとめ]とか[クチセット]とか違う名前を付けてね。

レイヤフォルダ名が[クチ]だとそっちの名前が優先されちゃって中身が合成されちゃうよ!


1-7.輪郭を描きます

表情パーツを描き終わったら、今度は頭や身体のパーツを描いてゆきます。

まずは、輪郭を描きましょう。
輪郭

輪郭

描けたら、レイヤー名を[輪郭]と設定します。

えもこのワンポイント!

今回はシンプルテンプレートだから、耳やもみあげ、頬の色や髪の影なんかも輪郭に描いちゃってOKだよ!

長いもみ上げは次に描く前髪の一部にしちゃうと綺麗に動くと思うよ。

もちろん、ベーシックテンプレートならそれらのパーツも別々に描いて綺麗に動かすことができるんだよ!


1-8.前髪・後髪・胴体・胸を描きます

輪郭以外の、身体を構成するパーツを描いてゆきます。

前髪・後髪・胴体・胸

前髪・後髪・胴体・胸

・前髪

まず、前髪全体を別のパーツとして描きます。輪郭を全て覆うように描くのがコツです。
尚、前髪が無いキャラクターは省略しても構いません。
描けたら、レイヤー名を[前髪]と設定します。

・後髪

次に、耳や首より後ろ、頭頂部から後頭部にかけての頭全体と髪をまとめて後髪として描きます。後髪が見えないキャラクターは、省略しても構いません。
ポニーテールや髪を後ろで束ねているようなキャラクターは、これを作成します。
描けたら、レイヤー名を[後髪]と設定します。

・胴体

腰から上の胴体、腕・首をまとめて描きます。
首は輪郭に鼻のあたりまでめり込むくらいまで描くのがコツです。
描けたら、レイヤー名を[胴体]と設定します。

・胸

胸を揺らしたり、胸で立体感を出したい場合は胸を描きます。
男性キャラなどの場合はレイヤーを作らなくても構いません。レイヤー名は[]と設定します。

これで、体用パーツの作成は全て完了です。

えもこのワンポイント!

髪や胸はどう動かすか悩むよりも、とりあえず描いてみるのがオススメ!

E-moteに取り込んだ後も何度でも描き直しができるから、
まずは動かして、それから色々考えてみてね!


1-9.トリミング枠を作ります

キャラクターを表示させたい範囲を、四角の画像で設定します。
トリミング枠

胴体の下部分が少しはみ出すように、身体全体を囲うのがコツです。
トリミング枠

中まで塗り潰して[トリミング枠]とレイヤー名を付け、キャラの下に敷いて下さい。

トリミング枠

えもこのワンポイント!

トリミング枠は、必ず内側まで綺麗に塗り潰してね!

穴が開いていたり、半透明になっていると、キャラクターが欠けて表示されてしまうので注意だよ!

それと、前にもえもふりを体験してくれた人はもう気づいたかな……?

えもふり3.9では、頭部全体枠や胴体全体枠、目や眉の枠設定が無くなったんだよ! トリミング枠以外は全部自動で枠を作ってくれるようになったんだ。すごいね!

 


1-10.背景も作成してみる

E-mote3.9シンプルテンプレートでは、[背景]も作成できます。
背景

背景にしたい画像を作成して、レイヤー名は[背景]と設定します。

えもこのワンポイント! ちなみに背景はトリミング枠でも切り抜かれないよ。必要なければ描かないでもOK!

1-11.最後に、それぞれの中心軸を決めます

最後に、首の回転中心、胴体の回転中心、全ての中心の3つを決めます。
それぞれの中心軸を決めます

それぞれ、別のレイヤーで作成します。
各中心点の画像は、点を打つだけでOKです
(点の中心が、最終的な中心点となります)

  • 首の中心点は首を傾げる時の回転中心となります。
    閉じたクチの少し下あたりに打つのがコツです。
  • 腰の中心点は、バストアップの場合は胸の少し下、
    前項で作成したトリミング枠の外側に打つと綺麗に動きます。

中心軸

  • ・全ての中心点は、キャラ・背景全体を回転させる際の中心軸になります。
    特に理由が無い限りは 画面全体の中心に設定すると良いでしょう。

それぞれのレイヤー名を[首中心][腰中心][原点]と設定します。

えもこのワンポイント!

「首中心」は首の付け根、「腰中心」はヘソ、「原点」は絵の中心だよ!

間違えないように気を付けてね!

 

お疲れ様でした! これで、psdの準備は全て完了です!

最後に、ここまでで表情8枚、身体5枚、設定5枚のレイヤーが用意出来ているかチェックしてみて下さい。レイヤーの順番も、見た目問題無く重なっていればOKです。

問題無ければ、次項からはいよいよ、E-moteキャラクター化作業に入ります!


■2.作ったキャラクターをE-moteに登録しよう!

いよいよE-moteキャラクターの作成です。
E-moteエディタを使用して、キャラクターの画像を各パーツに登録してゆきます。
まずは前項で作成したpsd画像最新版のえもふりエディタを用意して下さい。

※ ご注意! 本マニュアルで作成したpsdには、必ず[シンプルテンプレート(.emttmpl)]を使用してください。
 シンプルテンプレート以外を使用すると、レイヤ名が異なり眉や口のパーツが正しく表示されません。

えもこのワンポイント!

エディタやテンプレートは、必ず最新版を使ってね!

古いE-moteエディタだと、新しいテンプレートを読み込めない事があるので注意が必要だよ。

もし読み込めなかったら、最新版をダウンロードしに行こう!


2-1.エディタの起動・テンプレート読み込み

E-moteエディタを起動して、左上メニューの[ファイル]-[テンプレートを開く]から[シンプルテンプレート_正面タイプ.emttmpl](または左斜めテンプレート)を開いて下さい。
テンプレート読み込み

すると、エディタに白黒のテンプレートキャラが表示されます。これが、E-moteの基本テンプレートキャラクターです。
E-moteの基本テンプレートキャラクター

基本テンプレートキャラクターには、様々な動きや表情変化の仕組みが既に構成されています。
このキャラクターに、psd形式で作成した各パーツを当てはめ、差し替えて新たなキャラクターを作成します。


2-2.PSDをインポートする!

[ファイル]-[psdをインポートする]から、先ほど作成したpsdファイルを読み込みます。
PSDをインポートする

PSDインポート画面が開きます。
ここで、をE-moteエディタに登録します。
psdで作成したキャラクター

まず、画面左上の「取り込みパーツ一覧」の文字が全て黒字で表示されているのを確認して下さい。

赤字や灰色表示されている場合は、そのパーツが省略されているか、またはレイヤー名が間違っている可能性があります。胸や後髪などを省略していないのであれば、一度キャンセルしてPSD画像のレイヤーや、レイヤー名(特に英字の半角大文字など)を確認して下さい。

取り込みパーツ一覧の各パーツ名をクリックし、パーツが青色の枠で正しく囲まれているかを確認しましょう。
異常に余白が大きかったりする場合は、psd画像に見えないゴミやドットが残っており、それをパーツの一部として認識している可能性があります。

psd画像に見えないゴミやドット

えもこのワンポイント!

正しい枠が取れていないときは、一旦[キャンセル]して、psd画像を見直してみてね!

異常な枠でインポートしてしまうと、後で動きの調整が大変になったり、キャラクターが綺麗に動いてくれなくなるよ!

 

それぞれの枠に問題が無ければ、「インポート」ボタンをクリックしてPSDからキャラクターパーツを取り込みます。
PSDインポート完了!

psdで作ったキャラクターがE-moteエディタ上で、psd作成時と同じように表示されていれば、PSDインポートによるパーツの登録と位置・重ね順調整はすべて完了です。

(ね!簡単でしょう?)

えもこのワンポイント! psdにおかしな部分は無いのにパーツが欠けてしまっていたり、
うまく表示できない場合はもう一度[リセット]してからインポートし直してみてね!psd側のレイヤー名が間違っていないかどうかもチェックしてね!

2-3.一旦プロジェクトファイルを保存しましょう

プロジェクトに名前をつけて保存する

psdインポートが完了したら、一旦プロジェクトファイルを保存しておきましょう。
上メニューの[ファイル]-[プロジェクトに名前をつけて保存する]から、新しい名称でキャラクターファイルを保存できます。
テンプレートフォルダとは別の場所にデータを保存して下さい。


■3.キャラクターの細部を調整しよう!

E-moteはパーツを取り込んだだけでもある程度動いてしまいます!
ですが、もっと綺麗に、違和感無く動かすために動きを微調整する事ができます。


3-1.とりあえず、動かしてみる!

まずは色々と動かしてテストしてみましょう。
2つの編集モードでキャラクターの動作テストができます。
また、この2つのモードは、後々キャラクターのポーズや仕草を作るときにも使用します。
ポーズ詳細編集

まずは、エディタ左側にあるツリーの、[ポーズ詳細編集]を開き、[パラメータ編集]を選択しましょう。

・パラメータ編集

パラメータ編集

[パラメータ編集]では、キャラクターを実際にマウスで動かしてみたり、
スクロールバーを使ってキャラクターの細かい動きの確認が出来ます。

キャラクターのマウス操作は以下の方法で可能です。

CTRL+マウスドラッグ 目線・頭・胴体の向きテストができます。
SHIFT+マウスドラッグ 左右・前後の傾きテストができます。

 

今度は、エディタ左側のツリーから、[ポーズ詳細編集][物理挙動編集]を選択しましょう。

・物理挙動編集

物理挙動編集

物理挙動編集では、様々なボタンを押すことでキャラクターの動作を確認・設定できます。

えもこのワンポイント!

「パラメータ編集」では、ctrlやShiftを押しながらグリグリ動かせるよ!色々選んで組み合わせて動かしてみてね!

組み合わせ過ぎたりボタンを押しすぎて戻せなくなった時は、[パラメータリセット]を押すと元に戻るよ!覚えておいてね!


3-2.おかしな部分を調整してみる!

2つのモードでキャラクターを操作してみると、「あれ?」と思う部分が出てきたと思います。
ここではいくつか具体例を挙げて、調整方法を紹介します。

□頭の動きに目やクチが付いてこない・浮いて見える

頭を上下左右に動かした際に、絵柄によっては、目鼻クチ眉が輪郭の動きに対してズレて見える場合があります。
その際は、以下の手順を参考に調整をしてみて下さい。

1. [パーツ編集]を開き、[表情]-[表情全体座標調整]を開きます。
[メッシュ(頭向き・上下)][メッシュ(頭向き・左右)]を選択して、
[右]や[左]など、目や口の位置がおかしく見える顔の向きを探しましょう。

メッシュ(頭向き・上下)
メッシュ(頭向き・左右)

 

2. おかしな向きの顔を見つけたら、表示されている枠の中心を掴んで、動かしてみましょう。
目や鼻が動いて、大まかな位置を調節できます。
丁度良い位置に来るように調整してみましょう!

動かしてみましょう

3. これで、この顔向きの時の表情の位置が直りました。
他の顔向きでもおかしな所が無いか、調べてみましょう!

調べてみましょう!

顔全体に限らず、「片目だけ」や「前髪」など、頭を上下左右に動かした際の前髪の位置や形状、
胴体と首の繋ぎ目、瞳の動きなど、ほぼすべてがこの手順で、調整できます。

調整できます

調整できます

おかしな部分や気に入らない部分を見つけて、どんどん直してしまいましょう!

えもこのワンポイント!

おかしな部分を見つけたら

「1.ツリーからその部分を選ぶ」「2.おかしくなっている向きを選ぶ」「3.おかしく見えないように調整する」

が基本だよ!この方法でおかしな部分をどんどん直してね!

 

髪の毛が揺れすぎる・全然揺れない

シンプルテンプレートでは、揺れるパーツは前髪と後髪のみとなっています。
インポートしただけの揺れパーツは、パーツが大きいと大きく揺れ、パーツが小さいと小さく揺れて見えます。
また、髪の毛の形状によっては揺れてしまうとおかしくなる場合もありますので、ここではその揺れの調整方法を紹介します。

方法1:パラメータ設定を変更する

[物理挙動編集]モードで、[パラメータ設定]を選択します。
ここの一覧から、前髪や後髪、胸などの揺れタイプを設定する事ができます。
揺れタイプは重力・伸び・空気抵抗などのパラメータで構成された幾つかのパターンから選択します。
揺らしたくない場合は、「無し」を選択する事もできます。

パラメータ設定を変更する

方法2:揺れメッシュを調整する

1.後髪の揺れ幅を調整したい場合は、
ツリーから[パーツ編集]-[頭部]-[後髪]-[メッシュ(髪揺れ)]を順に選択します。

メッシュ(髪揺れ)

2.メッシュエディットから[左]を選択すると、髪が一番左に揺れた時の変形状況が表示されます。

左

3.表示されている枠内で右クリック、[少し抑制する]や[少し強調する]を選択し、
理想的な揺れ幅になるまで繰り返します。
(枠を直接つかんで調整もOKです)

少し抑制する

4.丁度良い揺れ幅に出来たら、作業終了です。
今度は逆方向の揺れも調節しましょう。

作業終了

えもこのワンポイント!

髪や胸の揺れ幅は、あまり強くしすぎるとちょっと動いただけでガクガク揺れてしまうから気を付けてね!

シンプルテンプレートではちょっと足りない目に調節するのがコツだよ!

眉毛の表情が気に入らない

眉毛や、目など、感情表現の時に自分の想定とは違う形になってしまっている事があります。
それらは調整し、理想に近づけることができます。
以下の眉の調整手順を参考に、目やクチなども調整する事ができます。

1.[悲しみ]状態の眉の形を調節したい場合は、
[表情]-[眉]-[メッシュ(眉・表情)]を開いて、[悲しい]を選びます。

悲しい

悲しい

2.青枠を操作して、理想の形になるように調節しましょう。
理想の形になるように調節しましょう

3. 調節出来たら、今度は逆側の眉も調節しましょう。
青枠上で右クリックし、[コピー]や[ペースト]、[形状を変形する]-[水平方向に反転する]などを利用すると楽です。

コピー

形状を変形する

最新版では[ツリ目]や[タレ目]、[微笑]や[不満]など、目やクチの微妙な表情も調節できます。色々試してみましょう!

目やクチの微妙な表情も調節できます

えもこのワンポイント!

今回のチュートリアルで紹介した方法以外にも、パーツによって様々な調整方法やノウハウがあるんだよ!

詳しくは[E-moteオンラインマニュアル(モーション作成の手順)]や、E-mote公式Forumを見てね!

 

以上で、シンプルテンプレートでのキャラクター調整例の紹介は終了です。

次はいよいよ動画を録ってみたり、ゲームやアプリに組み込んでみましょう!


■4.動かしてみよう!キャラクターを出力しよう!

これまで作業でキャラクターのパーツ作成・パーツ変形の調整を行ってきました。
この項からはキャラクターを実際に動かしたり、ポーズを組合わせて動画やアプリ上で動かすキャラクターデータを作る作業に入ります。


4-1.タイムラインを選んでみよう!

E-moteには[タイムライン]という、キャラクターの表情や仕草を作る
「動きのスケジュール表」のような仕組みがあり、シンプルテンプレートでは大量に用意されています。

タイムライン

1. 物理挙動編集モードを選んで、[タイムライン(メイン)]と[タイムライン(差分)]の選択項目がある事を確認します。
タイムライン(メイン)]と[タイムライン(差分)

2. 試しに、[タイムライン(メイン)]を開いて、[]を選んでみましょう。
すると、作ったキャラクターが少し嬉しそうな動作をしてくれたのではないでしょうか。

sample_02作ったキャラクターが少し嬉しそうな動作をしてくれたのではないでしょうか。

3.今度は、[タイムライン(差分)]を開いて、[歩行ループ]を選んでみましょう。
キャラクターが上下に揺れ出し、歩いているかのような動作が加わったと思います。

歩行ループ歩行ループ

これが、タイムラインの仕組みです。
タイムラインを組み合わせる事で、様々な仕草と表情を作り出すことができます。

えもこのワンポイント! タイムラインはえもふりエディタ上で動かすだけでなく、
ゲームに組み込んでそのままの名前で再生する事もできるんだよ!モチロン2つだけじゃ無く、いくつでも組み合わせることが出来るよ!最新版のえもふりはティラノスクリプトやUnityのデータ出力に対応しているから、
ゲーム制作に興味がある人は是非試してみてね!

4-2.タイムラインアニメーションを動画にしよう!

タイムラインは、wmv動画やgif動画、連番pngとして出力する事ができます。
早速、試しにtwitter向け動画を1つ作ってみましょう!

1. 左のツリーから[タイムライン編集]を開いて[sample_喜01]を選択し、[動画を出力する]のボタンをクリックします。

 

2.動画出力設定ウィンドウが開きますので、まずは以下の青枠内のように設定値を入力してみましょう!

(オフセットX・オフセットY)は、キャラクターが中央に来る程度に調節して下さい)

えもこのワンポイント!

gif動画は、サイズの大きな動画だと出力に時間がかかったりフリーズする事があるから注意!細かい設定は、モーション作成の手順・動画出力設定を見てね!

wmv形式の動画は、タテ・ヨコサイズがそれぞれ8の倍数でないと出力できないよ。注意してね!

 

3.[OK]ボタンを押し、ファイル名を決めて[保存]を押すと、動画の出力が開始されます!簡単でしょう?

動画(連番png)

やり方が分かったら、他のタイムラインも出力してみましょう!

※ twitterにUPできるGIF動画のファイルサイズは最大15Mまでです。
動画のサイズが15Mを超えてしまった場合は、動画の[幅]や[高さ]の値を小さくしてみてください。

えもこのワンポイント!

えもふりで出力した動画や、キャラクターを組み込んだアプリは自由に公開してOKだよー。

でも、企業での無断商用利用は禁止しているから注意!企業の人たちは正式版を買ってね!えもこからのおねがいだよ!

 

Pixivのうごイラ用動画出力は、以下の設定を参考にしてみて下さい。


4-3.タイムラインを自分で作ってみる?

用意されたタイムラインだけでは物足りないという人は、自分でタイムラインを作る事もできます。
まず、パラメータ編集モードや、物理挙動編集モードでポーズや表情の組み合わせを作ります。

カタログへ追加

組み合わせが出来上がったら[カタログへ追加]ボタンを押しましょう。
すると、[カタログ編集モード]にいま作成した表情組み合わせが登録されます。

カタログ

カタログへ追加された表情組み合わせはキャラクターデータに保存され、いつでも呼び出すことができるようになります。
また、それぞれに名前を付けたり順番を入れ替えたりする事もできます。

次に、ツリーから[タイムライン編集]を選択し、編集画面に表示される[新規タイムライン作成]ボタンを押してください。

新規タイムライン作成

すると、下図のようなタイムライン編集画面が表示されます。

タイムライン編集画面

タイムライン編集画面では、時間軸とパラメータを組合わせて、アニメーションを作成してゆきます。
細かな設定や調整も可能ですが、以下では簡単にアニメーションを作成する方法を紹介します。

タイムラインアニメーション作成手順

□1.

ポーズを決めたい時間(ポーズが完成する時間)にカーソルを合わせ、クリック。

時間軸のバーがその時間に来るようにします(時間軸のバーは、赤色でも青色でも問題ありません)

 

※ 作例では、30/60(0.5秒)に時間を設定しました。

□2.

[カタログから読込]をクリックし、カタログ一覧を呼び出します。

タイムラインアニメーション作成手順(入門用ver)

□3.

カタログから、先ほど作成しておいたポーズ・表情組み合わせを選択します。

※ 同じポーズ・表情のカタログでも、使用したくないパラメータがある場合は、チェックボックスを外してから選択する事で不要な部分を除外する事が出来ます。

タイムラインアニメーション作成手順(入門用ver)

□4.

カタログで選択したポーズが、先ほど決めた時間に表示されるように設定されました。

※ 作例では、タイムラインを再生して0.5秒後にポーズと表情の移行が完了するようになります。

タイムラインアニメーション作成手順(入門用ver)

□5.

同一のタイムラインで複数のポーズを取らせたい場合は、続けて、更に別の時間にカーソルを合わせ、□1~□3の手順を繰り返します。

※ 作例では、60/60秒目(1秒)目の位置にカーソルを指定しました。

タイムラインアニメーション作成手順(入門用ver)

□6.

指定した時間上に新しいポーズが追加され、前のポーズから続け表情・ポーズが変化するようになります。

※ 作例では、タイムライン再生を開始してから0.5秒後に

1番目のポーズ、そこから更に0.5秒後に2番目のポーズへと移行が完了する設定になりました。

タイムラインアニメーション作成手順(入門用ver)

作成したタイムラインは、タイムライン名の上で右クリックすることで表示されるメニューから、
名前を変更したり、クリップボードへエクスポートして保存、別キャラクターへ移植する事ができます。
色々作って保存して、自分だけのタイムライン集を作りましょう!

タイムライン名の上で右クリック

タイムライン作成のコツが解ってきたら、色々な動作や仕草のセットを作ってみましょう。
タイムラインは更に[ループ]や、[遷移イージング]など細かな設定も可能です。
詳細は、モーション作成の手順・5-3タイムラインを参照して下さい。

えもこのワンポイント!

タイムライン作成のコツが解ってきたら、色々な動作や仕草のセットを作ってみてね!

E-moteHPでは他にもキャラクター性別、性格別のタイムラインセットも公開しているから、
こちらも試してみてね!

 

4-4.アプリ組み込み用データも出力してみよう!

新バージョンのえもふりでは、「ティラノスクリプト」「Unity」組み込み用データの出力も対応しています。データの出力はとても簡単ですので、アプリ作成に興味のある方は是非試してみて下さい。

データの出力は、エディタ左上メニューの[ファイル]-[エクスポートする]から実行できます。あとはどちらのデータを出力するか選択するだけですので、とても簡単です。

えもこのワンポイント!

出力したデータには、前の項で説明したタイムラインが全部入っているよ!
スクリプトでタイムラインの名前を指定するだけで簡単に表情や仕草を呼び出すことができるから、是非やってみてね!

 

 

以上で、データの出力に関するチュートリアルは終了です!

色々試してどんどんUPしてみましょう!


■5.追加パーツを使ってみよう!

最後に、「追加パーツ」の使い方について説明します。
psd画像を作成しているときや、キャラクターの動きを設定しているときに、「使えるパーツが少ないなぁ…」とか、
「もっと細かく動かしたい!」と思いませんでしたか?
思った方には良いお知らせです。
E-moteは[追加パーツ]という仕組みで、もっと細かく、もっと沢山、魅力的にキャラクターを表現する事ができます!

追加パーツ

えもこのワンポイント!

シンプルテンプレートでは20個の追加パーツが使えるよ!

ちなみに、ベーシックテンプレートだとなんと99個!使えるパーツの種類もたくさんあるんだよ!すごいね!


5-1.まずは追加パーツを描こう!

最初に用意したpsdに、追加パーツとなる画像を作成します。画像は何でも構いませんが、
手始めに頭に付けるアクセサリーを作ってみましょう。

□1.

まず、追加パーツとなる画像を作成します。

他のパーツと同様に、透明部分にゴミなどが残らないよう、注意してください。

また、レイヤーの重ね順もそのまま登録されます。

正しい見た目になるよう、重ね順を決めて下さい。

ずは追加パーツを描こう!

□2.

作成したパーツのレイヤー名に、[追加パーツ_○○]または、[追加_○○]となるように名前を設定します。

(○○の部分は自由につけて構いません)

名前を設定したら、psdの準備は完了です。

ずは追加パーツを描こう!


5-2.追加パーツをインポートしよう!、調整しよう!

次に、psdに追加したパーツをE-moteキャラクターインポートして、

動作に違和感が無いように調整しましょう。

□1.

追加パーツを作ったpsdを、今までの手順で作成したキャラクターにpsdインポートします。

もしこのとき、psd画像のサイズや、原点を変更していた場合は、一度[リセット]ボタンを押してください。

正常にインポートできているのなら、取り込みパーツ一覧に[新規追加パーツ]という名前が青字で表示され、追加したパーツがプレビューに表示されています。

追加パーツをインポートしよう!、調整しよう!

□2.

取り込みパーツ一覧から、[新規追加パーツ]を選択します。すると、追加したパーツが一番手前に表示され、パーツタイプの選択項目が表示されます。

パーツタイプは、パーツを作った箇所に合わせて選択します。頭のパーツなら[頭部]、体のパーツなら[胴体]となります。次に、頭部全体枠や胴体全体枠に収まるパーツなら、[○○枠同期]を選び、枠に収まらないパーツなら[独立]を選択します。また、胴体にくっついているパーツの場合は、[胴体接着]が最適です。

最後に、揺れないパーツなら、[揺れ無し]を選び、揺れるパーツなら、一番イメージに近い[○○揺れ]を選択して下さい。

※作例では、[頭部]・[頭部枠同期]・[揺れ有り]を選択しました。

※ パーツタイプは、エディタ上では変更できませんが、ツリー最下部の[追加パーツ編集]から一度削除して、再インポートすれば登録しなおすことができます。

追加パーツをインポートしよう!、調整しよう!

□3.

左のツリーから[追加パーツ編集]を開き、追加したパーツを選択します。

それぞれのメッシュを開き、キャラクターを動かした時に違和感がなくなるように1つずつ調整して完成です。

ちょっと手間のかかる作業ですが、上手く作ればキャラクターが更に魅力的になります!

追加パーツをインポートしよう!、調整しよう!

追加パーツ・向きメッシュ調整のコツ

追加パーツ・揺れメッシュ調整のコツ

追加パーツ・揺れメッシュ調整のコツ

追加パーツ・揺れメッシュ調整のコツ

えもこのワンポイント!

説明が難しそうに見えるけど、基本はやっぱり、おかしな部分を見つけたら

「1.ツリーからその部分を選ぶ」「2.おかしくなっている向きを選ぶ」「3.おかしく見えないように調整する」

だよ!やってみれば意外と簡単だから是非試してみてね!


5-3.特殊表情も追加してみよう!

追加パーツとは少し異なりますが、最新版シンプルテンプレートでは、じつは目・眉・クチそれぞれに2つずつの特殊表情を追加できます。この仕組みを使えば、更に豊かな表情が表現できるようになります。

特殊表情も追加してみよう!

1.インポート用psdに特殊表情を追加してみましょう。
描き方は、通常の目・眉・クチと全く同じです。レイヤー名は[マブタ特殊1]・[白目特殊1]・[眉特殊1]のように、
名前の後ろに[特殊1]または[特殊2]を付けて下さい

特殊1

使用できるレイヤー名は、以下の通りです(数字は半角英数です)
[マブタ特殊1][瞳特殊1][白目特殊1]
[マブタ特殊2][瞳特殊2][白目特殊2]

[眉特殊1][眉特殊2]

[クチ特殊1][クチ特殊1開き]
[クチ特殊2][クチ特殊2開き]

えもこのワンポイント!

目はマブタと瞳と白目で1セット、クチは閉じと開きで1セットなのを忘れないでね!

もし忘れちゃったら、後で書き足せばOKだよ![クチ特殊1]と、[クチ特殊1開き]はレイヤー名を間違えやすいので注意してね!

 

2.特殊表情を追加したpsdをインポートします。
psdインポート画面で、特殊表情が読み込まれているか確認をして下さい。

psdをインポートします

3.問題無ければ、[インポート]してみましょう!
物理挙動編集で正常に表示されるか確認してみて下さい。

インポート

4.さて、登録できただけでは動画やアプリで使えませんので、タイムラインにも反映させましょう。
特殊表情を使いたいタイムラインを選択しm、[目・表情]や[眉・表情]、[口・表情]のタイムラインを選択します。

タイムライン

5.切り替えたい部分を選択し、上のスクロールバーを特殊表情が表示される所まで移動させましょう。
特殊目1は[30]、特殊眉は[50] 特殊クチは[40]で変わります。

特殊目1は[30]、特殊眉は[50] 特殊クチは[40]で変わります。

6.タイムライン全体の、必要な部分の数値を変更しましょう。右ドラッグで範囲を指定すると
一気にまとめて数値調整が出来ます。全部調整が出来たら、[再生]したり[動画出力]して確かめてみましょう!

タイムライン

えもこのワンポイント!

青いバー1つ分で、表情が1回変わるから、青いバーが何区切りにも分かれているときはその分表情が変わるんだよ。特殊目や特殊眉で固定したいときは全体を揃えるように注意してね!

あと、右クリックメニューでタイムラインの数値をまとめて増やしたり、逆にすることもできるよ!色々使ってみてね

 

これで、えもふりチュートリアルは全て終了です!

お疲れ様でした!


おわりに■

えもこ先生

えもふりチュートリアルをお読み頂き、誠にありがとう御座いました。
本チュートリアルを読みながらE-moteに触れて頂く事により、
お客様自身でE-moteキャラクターを作り、動かし、また作る楽しさと驚きをご堪能頂けていれば幸いです。

尚、E-moteの更なる詳しい仕組みや機能につきましては、他2点のマニュアル
E-moteオンラインマニュアル」をご参照下さい。

作成や使用にあたり、ご不明な点やご質問等ございましたら、E-mote Forumをご活用下さい。

また、オンラインマニュアルやオフィシャルHPでは、
随時マニュアル内容や新テンプレートサンプルキャラクターを更新してまいります。
そちらもお試し頂き、E-moteの表現力・手軽さに触れていただければと思います。

Ver3.9サンプルキャラクター「かける」(ver3.9)

最後に改めて、ここまでお付き合い頂き、ありがとうございました。

付録

E-moteシンプルテンプレート・psdレイヤー名一覧

[原点]

[首中心]

[腰中心]

[マブタ通常]

[瞳通常]

[白目通常]

[マブタ閉じ]

[眉]

[鼻]

[クチ]

[クチ開き]

[輪郭]

[前髪]

[後髪]

[胴体]

[胸]

[トリミング枠]

[背景]

[追加_○○] ※ ○○内は自由

[追加パーツ_○○]

~~~~特殊~~~~

[マブタ特殊1]

[瞳特殊1]

[白目特殊1]

[マブタ特殊2]

[瞳特殊2]

[白目特殊2]

[眉特殊1]

[眉特殊2]

[クチ特殊1]

[クチ特殊1開き]

[クチ特殊2]

[クチ特殊2開き]